Only the examplefiles work!?


#1

Hi!
I have connected the brick and the rasp correctly and i get all the examplefiles in the BrickPi_Scratch directory to work flawlessly BUT whenever i try to create my own project I somehow can’t get it to work. I never get the “Service started” confirmation. I have no idea what could be wrong and I desperately need help to solve this.
/Majen


#2

Majen, maybe you can post a screenshot of the program you wrote, or attach it, or link to it?


#3

Well We´ve tried to copy, let´s say the “car”, example i a new project but we can´t get it to work. It feels like something in the basic setup of the scratch connection to the Brick is wrong. Are there any properties we need to get right that is somehow preconfigured in the examplefiles?
/Majen


#4

So when you say you’ve tried to copy it, have you saved the file as a new name, and then opened it up again? Or have you tried to copy and paste from one program to another?

Just a note on the side, we’re working hard on Scratch at the moment. A lot of opeople have had trouble with it and we’ve hopefully got a simpler solution in the pipeline to be released very soon.


#5

We are having a near identical issue. Although, we do get the service started confirmation. When we run the examples, we get two other things back: “Setting up sensors done” & “Service Started”. We do not get these when we try and create our own projects, only the “Service Started” message. Any help is much appreciated.


#6

Any solution to this, I just acquired the product last week and the same problem.
If I load the examples (works perfect) looks like there is a type of hidden setting since after that
I can code from zero and the application works.
If I try writing the exact code just after I open Scratch, it never works.


#7

Hey Chamiza, did you run the BrickPi_Scratch program in the background? And is broadcasting turned on when you’re running scratch?