Power with WiFi


#1

First time Raspberry Pi user, and I have so far been very happy with the Brick Pi package. I got the ready to go package, and have so far been able to get everything working over wifi, including internet, PuTTy, VNC, and the Adafruit Raspberry Pi WebIDE. I have tried some python examples that worked well, motor tests etc.

The problem I have is that when I built the simplebot and unplugged the RPi usb power supply, and tried to run it remotely over wifi with a 6AA battery pack, after about 10 seconds of operation the wifi stops working because of the power draw. Unless the batteries are absolutely brand new out of the packet, the motors stop working as well. I also tried an 8AA battery pack which performed about the same. So, with only two motors and a wifi dongle, the battery power supply is insufficient for independent operation. I confirmed this by reconnecting the usb power supply along with the batteries and it worked fine for about 10 minutes before I stopped testing. I have looked in these forums and realize that the power draw of the RPi is a problem, but I didn’t think it would be this drastic.

I assume this is because my wifi dongle is probably not the most power efficient, but even if I replace it with a newer, better one, what sort of battery life can I expect and are battery-only powered projects really viable with the BrickPi, especially if I also want to use the ultrasonic sensor or more motors? Will modifying the BrickPi to the “upgraded power” version make much difference in this case? I have also heard suggestions of modifying the usb ports on the RPi to allow more power supply - is this possible/safe? Thanks for any help.


#2

That’s a big bummer. I’m just getting mine put together and had hoped to use 6x pack with Sanyo Enloop batteries. Hopefully the higher capacity will help.

I bought a relatively small 11,300 mah battery a week ago. I assume I can run a separate battery pack through the Pi’s microUSB port while powering the BrickPi off the battery pack. Would be ugly but at least it would be mobile.

Best,

Jack


#3

It sounds like there is a HW problem somewhere, or else you are using bad batteries.

I’ve used a 1500mAh 7.2v battery pack to power a RPi+BrickPi robot with WiFi for several hours without the battery pack going dead. This was without powering the RPi through USB, only using the battery pack connected to the 9v power input of the BrickPi.

The upgraded power BrickPi version is significantly more efficient, and could save a considerable amount of battery power.

I also seem to recall a USB modification people would sometimes do to their RPi. However, I’m fairly certain that was with Rev 1 RPis, and is irrelevant with Rev 2 RPis (which have this “fixed” permanently). I think it was so that people could backfeed power to their RPi using a powered USB hub, which means it should be unrelated to the problem you seem to be seeing.


#4

So with reference to potential HW problem, because I’m certain the batteries are fine: I tried the LED test examples in python in the BrickPi_Python Sensor_Examples, and only one of the LEDs works. I checked against the video Dexter Industries uploaded here where there are two, and I only have the one on the connection pins side working. Not sure if this has anything to do with my power problem, but could this indicate some kind of HW problem? I have tried using other batteries etc since my last post, pretty sure there’s no problem there. Also, maybe I should mention that I am using a D-link DWA-110 usb wifi dongle, its several years old and really big, is it possible that its just a massive power hog compared to newer ones? Any help is appreciated, thanks for the replies.