Problem when starting


#1

Hi John,
I had two of Brick Pi starter kits for my sons for Christmas, then with your help I got them up and running.

Then, somehow one just stopped turn on. Then another. I thought maybe something to do with the card so I purchased new card and following the instruction. http://www.dexterindustries.com/howto/raspberry-pi-tutorials/install-raspbian-for-robots-image-on-an-sd-card/

I am following the instruction but I cannot to get terminal installing wheezy img. I have been following everything I can see but would you be able to help me what would be the problem, please?


#2

Hi Shizu, sorry to hear about these troubles. So the problem is that you’re not able to log onto the Pi, is that correct? You say “stopped to turn on”, by this do you mean you’re unable to reach it via SSH or VNC?

If that’s the case, let’s dive into why you can’t connect. Can you tell me more about how you’re trying to connect to the Pi?


#3

Hi John,
I just found that ‘Get Started’ instruction had changed!

I have tried with batteries then didn’t work well so I have powered up with mini USB directory from powerboard.
With the old instruction, pluged monitor, speaker,ether cable connected then powered up the pi, I started working on Bookreader. I got them working espeak and camera, then both of Brick pies stopped turned on one night!

By new instruction, it doesn’t mention about mini USB powered directory connected from powerboard I am guessing something to do with it. I will sort batteries and try out again. I will update again after it.


#4

Hi John,

I have tried with battery pack and they do work!
Even though mini USB does not seem to work.

Anyway, as I was trying to open VNC but I couldn’t get in. I might have damaged the card.

I got new sd card and followed the instruction.
http://www.dexterindustries.com/howto/raspberry-pi-tutorials/install-raspbian-for-robots-image-on-an-sd-card/

Followed -Using Mac, I have tried the command after unmounting my disk. sudo dd bs=1m if=2015.03.20_Dexter_Industries_wheezy.img of=/dev/disk3

I have changed disk number and asks the password, but I cannot type.

I have spend so many hours but no idea what is wrong… Would you be able to show anywhere that I might help install the cards? Or maybe buying already installed card might be much faster…


#5

Hi Shizu, I’m really sorry to hear about the problems. You wrote:

Followed -Using Mac, I have tried the command after unmounting my disk. sudo dd bs=1m if=2015.03.20_Dexter_Industries_wheezy.img of=/dev/disk3

I have changed disk number and asks the password, but I cannot type.

Did you place the SD card back into the Pi before trying to connect to it? It sounds like you unmounted it and then tried to connect without putting the SD Card into the Pi. No?


#6

Hi John,
Sorry I don’t understand what mount means even though I am trying learning :frowning:

I got new SD card and followed this instruction. https://www.raspberrypi.org/help/noobs-setup/

I have formatted the card, copied all the filed from 2015.03.20_Dexter_Industries_wheezy.img then pasted into the card.

I have started Brick pi, it started up but it says
’Kernel panic, not syncing : VFS : unable to mount root fs nonblocking pool is initialised’

What should I do now?


#7

Hi Shizu, no problem at all. I’ll try to walk you through this.

First, it seems there’s a problem with the SD card you have. It may have happened because of a power shutdown. Either way, if you’re seeing “Kernel Panic” the SD card is broken.

No worries. Let’s start from the beginning.

Can you try to follow these instructions:

http://www.dexterindustries.com/howto/raspberry-pi-tutorials/install-raspbian-for-robots-image-on-an-sd-card/

They will walk you through installing the SD card. Then, try restarting everything.


#8

Thanks John,
I have been working through it, each steps takes so many hours to figure out but having progress. If I couldn’t get through then I will purchase new card.
Cheers,


#9

Hi John,
I got to this step;

I have unmounted disks by disk utility.

On Terminal, installation succeeded by the command “sudo dd bs=1m if=2015.03.20_Dexter_Industries_wheezy.img of=/dev/disk”.

I ejected the sd card from my mac then placed it to the raspberry pi but not starting at all. It just turn red light only.

Is there any other way that I can install such as copy boot folder files?

Buying new installed card might be my option but I have already damaged two new cards so I’m nervous that I might damage new one again…


#10

Hi shizu, how long did installation take?

If you’re seeing only the red light, the image isn’t installed correctly on the SD card.

Copying boot folder files just won’t work unfortunately. Do you have a PC? Is it possible to try using the PC directions to install the image on the SD card?


#11

YES!
I have finally started up raspberry pi!
Thanks John! Every single steps took so long…

It looks like it’s raspbian, and somehow I cannot connect to VNC but I thought better let you know the great news.
Thanks for your support and can’t wait to move onto program interesting projects!
Cheers,
Shizu


#12

hi John,
I have a Brick Pi. When I buy this is working and i used two weeks. I put this away in my room. After one or maybe two year. I find my brick Pi and i wanted to use this but is not working. I thinked i have maybe do
bad handling and can be corrupt my SD Card. I format my sd cart and i follow instructions for install new image for my sd card. But after many essay, i have succeeded. But when i try to boot my rasberry pi is don’t work. I know what is the problem.
tanks


#13

Hi @bealongboard,

Can you tell us which image you are using on your Pi. Also what is the status of your LEDs on boot. Are you able to see the ACT-Green LED blinking on boot ? If this LED stays solid Green without blinking or if doesn’t turn on, then there your SD card might be corrupt or damaged. Also tell us what all have you tried with the SD card.

-Shoban


#14

Hi Shoban,

The image i using is the 2016.12.04_Dexter_industries_jessie.rar. Also, ACT-Green LED not blinking but it’s stays solid Green. My SD card is a SD card dexter industrie. I erased y SD card. After this, i followed the instrutions on the wedsite dexter industrie to install an new image.

Envoyé de mon iPhone


#15

Hi JohnC,
I was communicating with you yesterday, and then lost all power at home, and also lost my my communications messaging with you. You were helping me address and resolve an ‘AVR not responding’ issue as with the software/firmware download to the Raspberry pi board. Can you reach back out to me and offer your guidance.
Sorry, but I do not know enough about this Forum format to reach you any other way.
SteveM


#16

Hi @bealongboard,

Thanks for your patience, Can you tell us a little more about how the Ethernet LEDs are on boot, do both the LEDs blink and also how are you powering your Raspberry Pi.

Can you try booting your Pi connected to a monitor and tell us what you see.

-Shoban


#17

hi Shoban,
The Erthernet LEDs turn on ( the green and the orange) but it don’t blinking. After some second, it turn off. I powering my Rasberry Pi with the Battery Pack provided with my Rasberry Pi. When i try to booting, i see nothing. the monitor sets in sleep mode.

-Beatrice


#18

Hi @bealongboard,

Can you power the Raspberry Pi with a USB cable connected to the laptop and see if its a power issue. Also do not connect the BrickPi to the RaspberryPi while doing this. Please do send us a few pictures of your setup showing the top and bottom of your Pi. Sorry to have this taking a long time, we will try to do the best help possible.

-Shoban


#19

when I power Rasberry Pi with a USB cable connected to my computer is doesn’t work. but the internet LED don’t turn on. I try to boot my raspberry pi with a other SD card with the image 2016.12.04_Dexter_industries_jessie.rar and is doesn’t work.

-Beatrice


#20

Hi @bealongboard,

Sorry to keep this going long.Can you tell us how you tried to boot the Pi with the supply from your computer, the images show only the Pi, with no ethernet or wifi adapter. Can you post a video of booting your Pi with the USB cable connected to your computer and Pi connected to a monitor.

-Shoban