Problem with BrickPi Advanced Power board


#1

I purchased the BrickPi Advanced Power board with 12V power pack back at the end of January and have just gotten a chance to start experimenting with it.

I am having a problem with the board rebooting the Pi when one or two motors are switching direction with out stopping in between.

I have also implemented the program with both motors stopping before switching direction and the Pi continues to reboot when more than one motor is running.

Sometimes the Pi will reboot when only one motor is running ans switching directions even with stopping before switching directions.

I have tried using both the 12V power pack with fresh batteries as well as a power supply (wall wart variety, but of a higher quality) and experience the same problem.

I have tried running one motor on the A/B bank and one motor on the C/D bank with the same results.

Have not had a chance to put a scope on the power input from the expansion pins on the Pi board, but suspect that there may be a noise problem.

Any suggestions?
Attached is the python program I am using based on the test program for two motors posted by Jaikrishna.

At this point the Brick Pi board is useless to me if it will not drive at least two motors without rebooting the Pi and hate to think that I blew about $100 with my total purchase. So far the LEGO NXT switches and ultrasound sensor work just fine.

Here is the version information that I get when logging in via SSH with putty:
3.10.24+ #614 PREEMPT Thu Dec 19 20:38:42 GMT 2013 armv6l

I downloaded the latest image and created an SD card with it.

Thanks.
Scott


#2

Hey Scott,

First, is it possible to share the python code, but upload it in a text file? For some security reason our forums don’t let folks upload python scripts.

The Raspberry Pi resetting probably has to do with a power issue; when it detects the voltage dropping below 5V the Pi resets or shuts down. That could be because of a large power draw; it sounds like the motors are drawing a lot of power for some reason.

So, some questions then . . .

  • Are you running anything else on the Raspberry Pi? Like any programs or processes in addition to the python programs?
  • Your running this over Wifi, or over ethernet?
  • What sort of wifi dongle
  • Are the motors running free, or are they hooked up to something?
  • Which pi model are you using? The A or B?

I’m sorry for all of the questions, but I’d really like to try to understand this problem better. I would really like to try to recreate the problem on our hardware.


#3

Thanks for the replay and sorry for not getting back sooner.

Power draw or noise is what I suspect as well. I’ll try and get a scope on it this weekend to see if I can detect anything.

The only thing I start up is “tightvncserver” (have to do it manually for some reason so also have a putty shell running) and run from a VNC viewer on my laptop. Note: have not changed anything from standard installation.
See the process list below.

Running wifi
The wifi dongle I am using is one I ordered from Adafruit back last Aug.not sure if it is the exact same thing though since I ordered a second one for a Linux laptop in April and the CD’s that came with it are different.

Motors are pretty much running free. I have a small wheel and tire but have the robot suspended and spinning freely on my counter top.

Attached is the list of processes running from the model B pi: "processes.txt"
and the python script: “LEGO-Motor_Test_2.txt”

Thanks for taking a look at it.

I’d like to get this going so I can demo it to area HS students when I get the chance.

Here is a pic of the bot. Note: ignore the servo, it is not connected at this point.

V/R
Scott