Problems connecting


#1

I followed the instructions at http://www.dexterindustries.com/BrickPi/getting-started/

But I’m having trouble connecting to the Rasberry Pi.

I downloaded the image from the link and wrote the image to a disk. I modified the cmdline.txt file. It now looks like
dwc_otg.lpm_enable=0 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait ip=192.168.1.99
There are no newlines in the file.

But I don’t think that’s the problem. When I power it up, the red light is on. The ACT green light is flashing. But that’s it. There are no other flashing lights. FDX, LNK and 100 are not flashing. Which they apparently should be according to “Connect to the Pi Robot” page.

The green light is flashing 8 times. Which according to http://elinux.org/R-Pi_Troubleshooting#Normal_LED_status
means “8 flashes: SDRAM not recognised. You need newer bootcode.bin/start.elf firmware.”

I’m about to try one of the Rasberry Pi images to see if that works. In which case, it could be a problem in the BrickPi image.


#2

Milind,sorry to hear about the troubles with this. Indeed, when we set it up on our end, we do have all lights flashing after connecting to our Win7 machine. We’ve never seen this error before so we’ll try to help you out as best we can.
Just a few questions:

  • What operating system are you using?
  • What version of the RPi are you using?
  • Have you had a different RPi image on this particular SD card before? Interested to know how another image works for this.

#3

Wow. That was quick!

I’m using Windows 7 Pro SP1.

I’m using RPi B. I just got it today. I actually thought that the BrickPi included the Rasberry Pi. When you said “full package” in the kickstarter, I thought that’s what it meant. This is my first Pi so I guess more experienced users must have understood what you meant. It was only when I saw the Getting Started Video that I realized I was missing something :slight_smile: I ordered it a couple of days ago and just received it today so I’m assuming that this is the latest version.

This was a brand new 32GB Ultra Class 10 SDHC card that I just cracked opened. So it had nothing on it. I had some trouble installing or formatting the card. But it worked once I used another adapter.

I wiped the card and I’m in the process of writing the Rasbian image I got from http://www.raspberrypi.org/downloads. I’ll let you know how that works out.

BTW, I noticed that I can power the Pi using a micro SD Card. That’s convenient when I’m at the desk. Will it also power the BrickPi? Or do the power only flow from the BrickPi to the RPi?


#4

I had to log out and log back in to see this thread. Strange.

Anyway, good news with the Rasbian image. That works. The Red light is on. When it’s accessing the SD Card, the green ACK light flashes. The FDK, LNK green light is solid as is the yellow 100 light. Although the LNK and 100 lights occasionally flicker.

I’ll try reflashing the BrickPi image and see how that goes.


#5

Well, good deal that your RPi is working! Let me know how the re-install goes. Thanks!


#6

I’m afraid that reflashing BrickPi brings no joy. I’d be interested to hear if anyone else has managed to get the modified wheezy image working.

I looked at the instructions to modify a working wheezy image. But I’m on Windows and the instructions look a little daunting to me. So I did the next best thing. Given that it seemed that bootcode.bin/start.elf were indicated to be problematic, I replaced the ones in the BrickPi image with the ones from the Raspbian image.

That worked! But I’m not sure if that’s kosher.

bootcode.bin
BrickPi: 18KB 5/25/2013
Raspbian: 18KB 9/4/2013

start.elf
BrickPi: 2626KB 5/25/2013
Raspbian: 2440KB 9/4/2013

Would either of these files be modified by the changes you have made? If not, I think I’ll be fine. Otherwise, something down the road is going to fail when I start programming the BrickPi.

BTW. Is it just me or does everyone have a problem that they can’t see a conversation update unless you logout and log back in? I have tried this on Firefox and Chrome. And both seem to have the same problem.


#7

(I have the same problem with the forums. I’m trying to correct this issue.)

I’m not experienced enough with Linux to tell you if that will work or not. I’m also curious if the file has been corrupted along the way somehow.

Ok, I’m going to go ahead and download the image and give it a shot myself and see if I have the same problem. It could be corrupted with Google Docs and we might have to host it somewhere else. Let’s see.

If you want to go at it though, you can look at the “Modify Your Own Image”; critical to getting going are setup wiring Pi, set the UART clock speed, serial for python, enable GPIO Pin access. The other parts are just icing on the cake, those are the critical changes to make on a Raspbian image to get going.


#8

milind,
I just went out, bought a new 4GB SD card, and downloaded the image from this link:
https://docs.google.com/file/d/0B0WChwP4CnLBMVNKajMydy1VcVU/edit?usp=sharing

I installed as per the instructions on http://www.dexterindustries.com/BrickPi/getting-started/pi-prep/ , just going step by step, so I could try to think through the problem. I used the Win32 software to burn the image.

It worked succesfully for me. That leaves me super-stumped because I downloaded the same image.

I’m wondering if it’s possible the image you downloaded got corrupted somehow. Is it possible to try downloading a second time?


#9

I used the same links and the Win32 software. I’ll try downloading again tonight and get back to you. Can you post the MD5 checksum of the image you used (would be a good idea to also add that to the Getting Started Page) so I can confirm that it’s not a corrupted download. Although it’s a zip file with the image so I expect that’s unlikely to be the problem. Still… Worth checking. Easy enough.

I don’t have a Linux box to modify the image. From the quick glance I had at the instructions, looked like I’d need that.

I’m surprised that I don’t see more activity in this forum. I thought it would be buzzing with folks getting the BrickPi now. If I’m the only one with a problem, then it would seem to indicate some problem somewhere in my setup. Maybe the OS, driver, software, the card or the drive or something on my end.

Once I get this going, I’d like to check with some kindred folks to see if we could get some Java development going. Would make it a lot easier to develop in Java on my PC and push it to the Pis.

BTW, one question I had was whether I could use the micro USB on the Raspberry Pi to power the BrickPi.


#10

Just tried re-downloading the image from Google Drive and flashing it again. No dice. I also tried it on a class 4 4GB Sandisk Micro SD card using a SD Adapter. That didn’t work either. So it’s not the card itself. Could still be the something else on my PC. At this point, I’ll just wait to hear from other folks and carry on with what I have and see if I run into a problem. One other thing I can try tomorrow is try using my laptop with a different drive. If that too doesn’t work, then most likely it’s something in the image that’s working on your machines (or at least on some machines and not on others).


#11

Dang. I’ll continue to try to think of a way I can recreate the problem on this end. Maybe I’ll put the file up for download from another site like Dropbbox? Could that possibly help?

Just to confirm: when you run the RPi with the BrickPi image, without connecting to the network or your computer, does it start normally? Are you able to get it working with a keyboard and HDMI monitor?


#12

I could try with a file from Dropbox, but I’m beginning to doubt whether that’s the problem. The MD5 Hash of the image file is f574748d229e2cc781ead849397ca0d5 (I used the Win32 Disk Imager to get it). If it matches yours then that will rule out a corrupted file.

If I use the SDCard created with the BrickPi image (with or without the cmdline.txt being modified), the RPi doesn’t even boot up. The ACK Green light flashes 8 times. If I replace the bootcode.bin and start.elf files on SDCard created using the BrickPi image with the ones created with the Raspbian image from http://www.raspberrypi.org/downloads, RPi boots up. I have connected the RPi using a keyboard/mouse and HDMI cable to my monitor. And VNC works as well.

I was able to get a static IP address on the Pi. But it wouldn’t connect to the internet. With a little Googling, I made changes to the /etc/network/interfaces file and I was able to get the Pi connected to the net.

One thing I have noticed is that the Pi can’t handle much of a load. I don’t know if it’s because it’s a restricted profile kind of a device or a problem with the bastardized image I have. But the browser shoots the CPU usage to 100% and after a few minutes, the Pi is totally unresponsive and I have to hard reboot it. I installed Oracle Java using the instructions at http://www.raspberrypi.org/archives/4920 and it pretty much brought it to its knees. Oracle Java being available yesterday is serendipitous :slight_smile: I’m going to check with the base Raspbian image to see if the CPU load is a function of the BrickPi image or inherent in the Pi.


#13

Hey millind, I get the same MD5 hash as well: f574748d229e2cc781ead849397ca0d5

Hmm. Now I’m stumped.

I haven’t used Oracle Java on the RPi, so I’m not sure how that affects it. I don’t think the BrickPi image should be running that hard (certainly doesn’t on the Pi’s I’ve used it with).


#14

I am also having the same issue to connect to the RPi. I had followed the getting-started instruction to update the ip in the cmdline.txt file, however I am getting connection timeout error when I tried to use VNC viewr to connect to the RPi.


#15

Hi milind,
just to follow up to see whether you ever got the BrickPi image to work?

Thanks,


#16

Only with the changes I made to the SD Card that I documented in Post #116


#17

Thanks milind. I will give it a try tonight to see whether it works for me or not. I will report back the status.


#18

milind,
I was able to connect to the BrickPi last night with BrickPi image. There were following few things I noticed that I had done different:

  1. Battery - I did not know my 9V battery was almost out of juicy. After I changed to a brand new battery, I started to see all of lights flashing.
  2. The Ethernet network adapter - the adapter took a little bit of time to identify. I was trying to connect to the BrickPi through VNC Viewer right after I saw all of lights flashing and was getting timeout error. Then I went into the control pannel->Network Sharing Center->Change Adapter Settings –> Local Area Connection to actually make sure the Local Area Connection had done with identifying the device. After that, I was able to connect through VNC.
  3. Classic Microsoft task - I need to reboot my Laptop before I did all of above.

Hopefully that helps.


#19

Thanks for the update kool.

So it does look like the problem is on my side. I started out with a new battery and it works just fine with the Rasbian image. I also had no problem with the network adapter. Very strange.

BTW, I’m using 64 bit Windows 7 SP1


#20

milind,
I am also using 64 bit windows 7 SP1. I also noticed that the battery is drain very faster. I had to use another brand new battery when I actually got it to work, and with multiple reboot :slight_smile: Oh, one more thing, double check the ip address line to make sure there is no newline. I found out the ip address was in the second line, but it was not showing when I edited in the notepad.

Question? What did you modify in the /etc/network/interfaces to get the Pi on the net? I know I can google it, but it will be handy and faster if you can share that info.

I am also wondering your question for Dexterindustries about powering the PI using micro SD Card since the battery drains so faster. Hopefully they will answer your question.

BTW, I will also give it a try for the Java to see whether I will experience the same issue or not.