Proper way to update the OS?

I just started getting into brickpi3 and rpi.
I had a spare kingston microSD so decided to flash my own card with the most updated raspbian for robots stretch image here which I believe was from April 5th?
I booted my rpi up and everything went smoothly. I first expanded the sd card to make use of all available space. I then noticed an icon to update the OS so I went through the gui and updated both the software and firmware for the robot. Cool so far.
I also bought a pi camera V2 module and had that hooked up so I figured I’d give that a shot too. I was following the official guide for starting up the camera which directed me to the command line.
sudo apt-get update, which worked fine.
sudo apt-get upgrade, initially worked… it was running so I kinda just left it while I went to make breakfast. When I came back, the monitor was black (in sleep mode), I moved the mouse, screen came back. This is when i noticed the upgrading had ran into a fatal error in the terminal.
I was back at the command line so the rpi was still responding fine.
I tried to run sudo apt-get update and upgrade again, but ran into some one-line error. I know I know… why didn’t I take a picture of the error *facepalm… I’m totally tech unsavvy haha.

So anyway, I close the terminal, only to notice that the OS menu bar up top has disappeared. Starting to not look so hot here lol. I click the desktop, now all my icons have disappeared… great… I go CTRL-SYSRQ-‘O’ to shut off pi. I boot up pi again, and this time it just hangs at the color-swatch screen. No raspberries for me… :frowning:

So I decide to start over and reflash the SD card hoping none of the hardware broke…
everything kiiinda works as expected, cept when I see the 4 raspberries at bootup, the first msg is:
[FAILED] Failed to start Load Kernel Modules.
See ‘systemctl status systemmd-modules-load.service’
everything else after reads [ OK ]
raspbian seems to boot okay.
I try doing the update icon again, the terminal briefly flashes then disappears…
I run sudo apt-get update/upgrade again, cept this time I don’t see any fatal errors…
So I’m kiiinda okay?..

Which brings me to a few questions… First of all, have I irreversibly broken something… Second, how should I generally go about updating? Should I have just stuck with the tool that was provided on Raspbian for Robots?
and possibly third are there any general workflows for going back and fixing these things that may be broken?..


1 Like