Putty problem


#1

Hi, I’m having a problem logging on to the raspberry pi. I have followed the construction instruction and downloaded the relevant software. However, when I have tried to log onto the pi, using putty, one of two things happens : 1)I get a host unknown message or 2)the putty boots up and requests the username and I type in pi but when it requests the password the software in no longer responds and it will not allow me to type anything in. Any thoughts?
Cheers,
Oz


#2

Oz,

How are you connecting? Wifi or ethernet?

Did you follow these directions to install the software: http://www.dexterindustries.com/howto/install-raspbian-for-robots-image-on-an-sd-card/

When you’re able to find the host, are you typing in the username “pi” and the password “robots1234”
?
John


#3

Cheers, for the reply,
I’m using the Ethernet cable however the dongle for the wifi is connected. I have a dexterindustries sd card so have presumed it is already imaged. When putty comes up it allows me to type in ‘pi’ as the username but will not allow any input for the password.
Cheers,
Oz


#4

Hey Oz, when you type in your password, you won’t see any movement. But the program is accepting characters. That’s a security measure in place on all Pi’s and linux systems. You should just type in “robots1234” and hit return. Does that do it?


#5

Hi,
I’ve sorted first problem by using ‘raspberry’ as password. This has allowed me to get as far as setting up the internet and start the procedure to update the sim. However, i left the computer running briefly and came back to find a message saying that the host and disconnected (or something to that effect). Putty was sitting with a message saying that the pi had to reboot now. Nothing else happened so eventually i switched it off then on again. I still had to use raspberry as the password and raspberrypi.local to connect to the pi. VNC viewer seemed to have changed in that the wifi config had changed to wifi setup. I clicked on setup and it appears to connect, however, every time i try to ping google it gives an unknown host message. I’m assuming the sim has not updated but obviously cannot update it correctly unless i can access wifi.
Cheers,
Oz


#6

Oz, you are using an old version of the Dexter Industries software and possibly outdated Raspbian for Robots image and GoPiGo firmware.

-Sparx


#7

Yup, looks like you’re using a dated version of the operating system. If you want to upgrade, you can find instructions for downloading and installing here: http://www.dexterindustries.com/howto/raspberry-pi-tutorials/install-raspbian-for-robots-image-on-an-sd-card/

You say

I clicked on setup and it appears to connect, however, every time i try to ping google it gives an unknown host message.

So you went through the steps to connect your Pi to Wifi. Did you receive an IP number? Can you send a screenshot of the wifi setup, connected?

While you’re taking screenshots, can you run “ifconfig” and post a shot of that?

Then, it sounds lik you got on the command line and typed “ping google.com” and got an error returned, is that right? Is the wifi network you’re connecting your Pi to connected to the internet?


#8

Hwould it make most sense to re-image the sim and then start again?
Cheers,
Oz


#9

I think it would be the fastest way to sort the problem. The directions for doing this are here: http://www.dexterindustries.com/howto/install-raspbian-for-robots-image-on-an-sd-card/

Do they look doable?


#10

So I’ve re-imaged the SD card. I’ve logged on via the Ethernet cable and set-up the wifi pinged google and been given the appropriate response- then nothing no response from the raspberry pi at all. I tried switching everything off and reconnecting via putty and vnc viewer. Every attempt is met with a ‘host unknown’ response. I’m not sure where I can go from here as the as the raspberry pi is not responding at all. Any ideas?
Cheers,
Oz


#11

So you’re able to connect to the Pi over ethernet, correct? And there are no problems making that connection, is that correct? You ping dex.local and you get a postiive response, is that correct?

Next you’ve succesfully setup wifi on the Pi: you can ping google.com and get a response.

Now you can’t ping from your computer to the Pi over wifi, is that correct?

Are you using a Mac or PC? Are your Pi and your computer connected to the same wifi network?


#12

hi sorry. I thought I had replied to this but it seems it has not gone through. The situation is as follows: I cannot log onto the raspberry via either the Ethernet cable nor the wifi. In both cases the response is ‘host unknown’.
Cheers,
Oz


#13

Can you try assigning a static IP to the Pi by following the instructions here for mac: https://www.youtube.com/watch?v=q7mdXGxBuDI and for windows: https://www.youtube.com/watch?v=P4yg8RYtTJs .

Do let us know if this helps.

-Karan


#14

hi, I tried following the instructions. The gopigo does not seem to be responding over the Ethernet, .e. the pc was receiving nothing from its prompt over the Ethernet cable. However, I changed the IP number as directed anyway - still no response and the usual host does not exist response.
Cheers,
Oz


#15

Ok Oz, just to confirm:

  • The Raspberry Pi is powered with a wall plug adapter through the micro-usb port right now.
  • You’ve re-imaged the SD card with Raspbian for Robots.
  • When you turn the Pi on, the Power on the Pi is solid, and the ACT light blinks. Is that happening? Or are they both solid?
  • When you plug the ethernet cable into your Pi, and then into your computer do the lights on the ethernet port turn on?

#16

hi,
yes the raspberry is powered via the wall adapter. The card has been re-imaged. On turn on the power light is solid. i’m not sure what you mean by the act light. The Ethernet lights turn on the green one flickers for a short period of time before going solid the yellow light is solid all the time.
Hope this helps,
Oz


#17

It does help. If the ethernet lights are blinking, the Pi is booting correctly. The problem may be that your Mac or PC is not connecting to the Pi, or unable to connect to the Pi for some reason.

I think we’ve asked a few times in this thread, I can’t find a solid response: Just to confirm: are you using a PC or a Mac?


#18

its a pc
Cheers,
Oz


#19

Ok, so when you plug the ethernet cable into your Pi, and then into your computer are you able to ping dex.local?


#20

Hi,
as I said in an earlier message: I managed to log on to the pi and set up the wifi connection and ping google, from this point on nothing has worked. I cannot get a response from the pi using the Ethernet or the wifi. In both cases I have tried to ping using dex.local and dex.local:1 as relayed by the instructions on your website. In each case a unknown host message is given. When looking at the LAN link up the computer appears to be trying to communicate(ie. sending packets) but there is no response from the pi (0 packets received).
Cheers,
Oz