Putty problem

I managed to log on to the pi and set up the wifi connection and ping google, from this point on nothing has worked. I cannot get a response from the pi using the Ethernet or the wifi.

Ok, I know this must be frustrating, but I’m still not following what’s going on. On one hand, you can login through ethernet, setup wifi, and then ping google. On the other hand, you write “I cannot get a response from the pi using the ethernet or wifi.” So if you can’t logon through ethernet, how are you logging on to the Pi?

That’s sort of the point I’m, not it won’t let me back in. After I managed it the first time it seems to have malfunctioned it hasn’t let me log back in since. Sorry, I obviously did not make that clear.

Ok, I think I understand. So now you can’t get it back up and running. I think your only option is to try to re-image the sd card since that was the last thing that got you there succesfully. Did you have a power event, like the power going out or the SD card ejecting while the power was still on?

hi, we are making progress! I re-imaged the card and have managed to get the motors to run via the Ethernet cable using the python test . I have set up wifi but I am unable to get any response from a Scratch command ( I have used the broadcast commands). I can get the little icons to move but the robot does not. What am I missing?

Great to hear that the image is finally working for you.

Have you tried testing the GoPiGo with python. For trying out scratch, can you try out this example first: http://www.dexterindustries.com/GoPiGo/projects/scratch-examples-for-the-raspberry-pi-gopigo/basic-scratch-robot/.


tried the above but no response from the robot?

Can you post a screenshot of the scratch program you’re running?

hi hopefully I have attached a screenshot of vnc viewer.

Hey Oz, thanks! That’s a screenshot of the desktop, but not the program that’s running. You need to click on the Scratch icon. When you do that and run the demo (there’s a button that will show up) what happens?

Hi, i’m not sure what you are asking for so I’ve put a few shots together for clarification. I get into the program and click ok on the remote sensor enabled message. after that I try using the commands but there is no response from the gopigo just the response from the software as in the last of the screenshots.

sorry had to add pictures separately in number order

and again

I actually want to see the dialog in the terminal window. I’ve got that circled in the attached picture.

Also, maybe you can share a test log with us? Here’s a short video on how to do this: https://www.youtube.com/watch?v=ZMadpIEYq5o&feature=youtu.be

here is the circled bit!

test log