Python Motor Test failing


#1

I have a BrickPi bought in mid 2014. I have followed the instructions for getting it built and connected.

I have set up remote access via WiFi from a Windows Vista Laptop, connected in via Putty, and successfully launched various X windows programs using Xming
After solving the challenges setting up the interfaces file to allow me to have a Wifi Connection for the console and an Ethernet connection to get internet access when I wanted it. I have now pulled the latest python related software from git hub, and set up file and folder permissions so that things seem to work from Nix perspective.

I have 6 fresh AA batteries and USB powering the system, and I can happily run programs on the Pi, so now I want to get things working on the BrickPi.

The setup.py process pulled packages from repositories, and installed the BrickPi.py and set up directories sensibly.

I am using NXT motors and sensors (in case that matters).

First program I ran was LED.py, which flashed the two LED as expected, LED_PWM.py then happily got the two LED operating in PWM mode to apparently dim and brighten.

I then tried the motor test programs in Sensor_Examples folder. The programs execute, but they fail to operate motors although the console output shows they are trying to do so.

I have changed motor cables for those I have working on a regular NXT brick.
I have plugged the motor cables into each of the four motor ports.
I have used two different motors, which both work fine on an NXT brick

I can’t find a way to use the Idle debugger, as I can’t launch Idle with sudo as it won’t display back over xwindows, and without sudo the serial port access fails.

I am now rather frustrated by this.

Your suggestions please…


#2

when the raspberry pi boots up, do you see any errors related to i2c or spi? if you do, it means the BrickPi drivers didn’t install correctly.


#3

I think woolfel’s suggestion is a good start, but the BrickPi runs on serial, not I2C.

Is there any way we can backup and check two things:
1). Your using your own custom image, Raspbian?
2). If you’re using your own custom image, did you work through the setup steps: http://www.dexterindustries.com/BrickPi/getting-started/pi-prep/
In particular, step 4: "4). The install script is called install.sh . Make it executable . . "

?


#4

I mentioned the errors, since i was creating a fresh image for my LOGi Pi experiment and after a apt-get upgrade a bunch of stuff stopped working :slight_smile:

I had to wipe my SD card twice and track down the upgrade caused stuff to break. the motor tests was running into issues all of a sudden after apt-get upgrade.


#5

Did you manage to figure out which upgrade caused stuff to break?


#6

not yet. I’m trying to figure out which package in upgrade-dist broke xwindows. I suspect libjpeg8-dev or some other graphic library. Luckily I saved an image after the second attempt, so now I have an easy way to revert back :slight_smile: I’m planning to post my raspbian image this weekend on github with Logi pi and brickpi installed on raspbian from 5-5.


#7

As far as I know I am on a standard build of Raspbian, we were given it on a teacher’s STEM course along with the Pi.

How would I find out exactly what build we have here (I am comfortable in bash shell, and familiar with Linux)

Looking at the boot screens while the boot happens is a bit challenging, as I am attaching over wireless that does not come up until after boot. Can you tell me where to look for the console boot log, and what to grep for?

Now I know that I don’t get an email ping when there is a respsonse to my post I will come back more often to check for answers…


#8

the command is uname -a

3.18.111-v7 is the version I am on.