Raspberry Pi Camera Not Working After sudo raspi-config

picamera

#1

I am having a problem with a new Picamera I purchased about a month ago. I am using a raspberry pi connected to a BrickPi and the rpi has a Dexter Industries Raspbian for Robots Jessie image, I have a program called “camera.py” written in python 2.7 that analyses a pixel color from an image taken by the camera. This program has worked flawlessly up until now, when I try to run the program and I receive this error message:

mmal: mmal_vc_component_create: failed to create component 'vc.ril.camera' (1:ENOMEN)
mmal: mmal_component_create_core: could not create component 'vc.ril.camera' (1)
Traceback (most recent call last):
    File "camera.py", line 5, in <module> 
        camera = picamera.PiCamera()
    File "/usr/lib/python2.7/dist-packages/picamera/camera.py", line 431, in __init__
        self._init_camera(camera_num, stereo_mode, stereo_decimate)
    File "/usr/lib/python2.7/dist-packages/picamera/camera.py", line 460, in _init_camera
        "Camera is not enabled. Try running 'sudo raspi-config' "
picamera.exc.PiCameraError: Camera is not enabled. Try running 'sudo raspi-config' and ensure that the camera has been enabled.

The problem is that I know from the start that I enabled the camera using sudo raspi-config the first time I hooked it up, and I did this correctly because as I mentioned earlier, the program worked well up until now. Moreover, I tried doing sudo raspi-config again, enabling the camera again and rebooting the pi, but still the exact same error message. I believe the camera is hooked up correctly as if it were not, it would not have worked the first time I ran this program.
I updated this SD card about two months ago(It had a Whessy image then) , but had to wipe it completely and install the new one because after the update none of my originally working robot programs worked (or this camera one as well), so I am very reluctant to update it again to avoid the same thing happening. Does anyone know what is going on, or if I should buy a new camera?

Thank you for your help


#2

Hi @radut,

Can you try taking a picture with raspistill?
Here’s the documentation on it:

What I want to see is if the camera actually works - maybe the ribbon cable was put the other way. This could explain the error you’re getting.

Thank you!