Raspberry Pi: WiFi and/or audio suddenly stop working after a re-install


I’ve run into an interesting problem while messing around with making multi-boot media, and I thought I’d share.

In summary, you’re messing around with operating systems, installing them on various media, and all of a sudden - you have a problem with WiFi and/or audio.  (In my case it has been WiFi and audio at the same time)

You may also have “modprobe” errors.

In my most recent case, (messing with Raspbian 64 bit), I tried to run Raspi-Config to see if I could shake this problem out, but it could not find the WiFi adapter and - when I exited raspi-config - it warned me of a modprobe error, looking for a modules directory when - in my case - the latest I had was 5.4.something.

The problem is that, somehow, your boot partition files, (specifically the kernel), and your root operating system have gotten out of sync.

In this particular case, I accidentally clobbered the Raspbian 64 boot partition by overwriting it with something like Raspbian 32’s boot - and, of course, it wouldn’t boot at all.  Once I figured out what the problem was, I went back to my original image for Raspbian 64, opened the image, and copied the files in the boot partition back over to my system’s Raspbian 64 bit boot partition.

It then booted, but had the strange problems I mentioned before.

The fix is to plug in the Ethernet, (that should work no matter what), wait for the time to sync, and then do an upgrade - as in “apt-get update” and “apt-get upgrade”.  That should get your system and your boot partition back in sync again and all will be happy.

If you get really strange errors when you try to do the apt-get update, that means your system’s clock is set wrong. Either set it manually, or wait for the internet to update it for you.

At least this worked for me.  (:wink:)

1 Like

Another thing:

I don’t know why, but sometimes the file manager behaves oddly - when I try to change anything that’s a preference, (or if I try to open the preferences dialog) - it “crashes” the desktop.

Sometimes it just won’t save preferences properly.

My solution:
sudo apt-get reinstall pcmanfm. <== This is the equivalent of “repair”.
I suspect that if a newer version is available, it updates it as in my case it downloaded a new package that wasn’t there before as part of the reinstall.  Either that or, (somehow or other), that package was missing/clobbered and it got replaced as if it were a brand-new download.

Apparently, whatever was broken gets fixed on a re-install.  At least I am one-for-one in tries and successes.

I am going to go further and suggest that a “reinstall” might well be the fix for many things that go all pear-shaped for whatever unknown reason.

1 Like