Raspbian For Robots OS shuts down when booting up

booting
r4r
gopigo

#1

Hello,

I’ve recently come across a GoPiGo2 kit. After assembling the car and attempting to connect it to my network, I ran into a few weird situations, including the inability to connect via ethernet cable.

To try to remedy that, I reflashed the SD card with the raspbian for robots (it was a 2015 version anyways, so I thought it’d be a good idea - I followed the instructions from here). After doing that, I can’t seem to boot the raspberry pi.

Plugging in a monitor via HDMI shows the normal boot sequence (with the services starting up), but then they suddenly begin stopping every service and the last line I am able to read is something to the effect of “Starting shut-down…” before the video output is stopped and the activity light on the pi ceases completely. The power light remains on, but the board is off and I can’t seem to pull up the command line or do any of the steps mentioned in the connecting tutorial.

I have tried multiple SD cards and double checked the md5 hashes of the downloaded OSs. Trying to boot up the official raspbian OS (not from dexter industries) works fine.

Is there anything I can try to troubleshoot this?

Thanks in advance.


#2

Hi @g.amb,

Let’s get these things straight:

  1. With a 2015 version of Raspian For Robots on your Raspberry Pi (stacked under a GoPiGo2), you’ve tried to boot it, and at some point during the booting process, the shutdown command was triggered.

  2. With a pure Jessie on your Raspberry Pi (stacked under a GoPiGo2) you’ve succeeded booting up the OS.

Here are a couple of suggestions of what you should do:

  1. Go with the latest version of our Raspbian For Robots OS. The last version was launched in this summer of 2017.

  2. Tell us if there’s any black foam stacked on your GoPiGo2. If there’s such a thing, then remove it as it’s causing this issue.

  3. Show us a photo of your setup.

That would be all for now.

Thank you!


#3

This is partially incorrect. With the 2015 version I got from the kit, the kit booted up, but I was having trouble setting up the networking. As such, I’ve flashed the July 2017 version and only then the shutdown command started triggering when I attempted to boot…

That is correct. Disconnected from the GoPiGo2 board as well.

As for the suggestions:

  1. The OS is already updated from the July 2017 version.

  2. The black foam was removed during the assembly of the car and is not present on the boot.

  3. Here is an album with the setup and the boot screens. I have also tried booting it while connected via ethernet, with little difference. http://imgur.com/a/Xpsmk

Thanks!


#4

Hi @g.amb,

We’ve only got the June 2017 version of Raspbian For Robots. There’s no July version.

Can you confirm us you have used the June version?
Here’s a link to the image.

There would be one more thing to test: can you try to boot up your Raspberry Pi with Raspbian for Robots on it with the GoPiGo2 board removed?

Thank you!


#5

Hey Robert,

My mistake. It was indeed the June version. Just in case, I tried it again downloading (and double checked the MD5 hash after extracting - it wasn’t corrupted). I flashed my SD card using etcher yet again and… the problem persists.

I disconnected it from the GoPiGo2 board and the issue didn’t change.

I did notice a particular line during the boot, though, maybe it is of some use for this troubleshooting?

“Failed to start Load Kernel Modules”

Thank you for your time