Raspbian Image on SD Card Before Starting Raspberry Pi


#1

I installed Raspbian for Robots Image on my SD Card before my first time ever starting my Raspberry Pi by following this tutorial:
http://www.dexterindustries.com/howto/install-raspbian-for-robots-image-on-an-sd-card/

Will I have any trouble when I start up my Raspberry Pi? Do I need to do anything to the Raspberry Pi too?

Can I start up everything by following tutorials to use my laptop’s screen and keyboard on my first time? Or do I need to first start it up with an HDMI display and keyboard?

Just FYI, My first project is this this air quality sensor:
http://wiki.seeed.cc/Grove-Air_Quality_Sensor_v1.3/

Thanks for any guidance you may be able to give.


#2

Hi @adevoid,

Thanks for choosing Raspbian For Robots.This video will let you know how the Pi boots up after a successful installation of Raspbian for Robots.

With our image you can get started with the Laptop’s screen and keyboard on the first go. To connect to your Pi with your computer click on option 1 here and follow the instructions to get started with your computer to connect to Pi.

Please let us know if this helps,
-Shoban


#3

I downloaded the Raspian for Robots image two different times, most recently using the following link:

Download 2016.10.14_Dexter_Industries_jessie.zip (1.6 GB)

After I downloaded it and unzipped it, I tried to open the disc image file but got the error that the disc image file is corrupted. The same thing happened when I downloaded the Raspian for Robots image from the link on Google Drive, the one with the word wheezy in it. What should I do?


#4

Hello @wolfenstein11x

I’m not too sure I understand what you’re doing. You’ve downloaded and unzipped the file without errors? Then you should have a file that ends with .img , right?
You can’t simply open that file. All you can do is “burn” it onto the SD card using either Win32DiskImage, or Etcher. I don’t know what you were trying to do exactly at this point. If you were simply double clicking that file to see what’s in it, that won’t work.
However if you were trying to load it into Etcher and having an issue there, that’s a different thing.

Could you confirm what you were attempting to do? We have a tutorial on how to burn the image onto an SD card here:
https://www.dexterindustries.com/howto/install-raspbian-for-robots-image-on-an-sd-card/
It would be great if you could tell us at exactly which point of the tutorial you’re experiencing the issue you’re facing.
Thanks
Cleo


#5

I downloaded and unzipped the file. The file does not say .img at the end
of it, but it does say “disc image file” under what type of file it is. I
attached a screenshot of exactly what the file looks like. I first tried to
burn the file onto the SD card by following the instructions, but upon
completion of writing the file to the SD card I got an error saying the
there was an I/O device error, error 1117. After that, I tried opening the
file itself, not knowing that that doesn’t work, but point is I’m trying to
burn the file to the SD card and am unable to do so. I want to know if I
need to get a new SD card, or if I’m doing something wrong.


#6

thank you for the extra details
It is possible that you don’t see the .img at the end of the filename, it depends on how your OS is set up. Since it is described as “disc image file”, we can assume it has the .img extension.

How big are your SD cards?
Are you using Etcher to burn the cards? Sometimes Etcher has a valid process but returns an error on the final check. It has happened to me a couple of times, yet the card was fine. I can’t remember if the error code I was getting was 1117 though.
Have you tried on another SD card? At this point the odds 50/50 between Etcher reporting a false problem and your card having an issue.

And btw, that’s is an old Wheezy image. From 2012?


#7

I will try a new SD card.


#8

I first tried using Win32DiskImager to burn the SD card, and that was when I got the I/O error number 1117. After reading your reply I tried using Etcher, and Etcher said there was not enough space on my SD card to burn the image on it. It’s a 4 GB SD card, the one that came with the BrickPi starter kit. Why would it say there is not enough space?


#9

With the Raspberry Pi Foundation moving on to Jessie as opposed to Wheezy (two flavours of their OS), it made the OS bigger. An 8Gig card is now required. We no longer sell the 4Gig cards for that precise reason.

Are you able to try with an 8Gig card?

Cleo