Removing unnecessary modules from modules.conf in R4R

When booting the current version of Raspbian for Robots, there is a failure message that scrolls by stating that “Load Kernel Modules” failed, which can set kernel status flags that are not very good for you.

Research disclosed that the offending module was “spi-dev”, which is referenced in /etc/modules-load.d/modules.conf.


# /etc/modules: kernel modules to load at boot time.
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.


The interesting thing is that the spi-dev module doesn’t even exist in the production version of Raspbian for Robots and Nicole has confirmed that it is an artifact from releases-gone-by that has, somehow or other, not been removed.  (And. . . she has already removed it from the code in their repository so it won’t be there in future releases.)

Since the module doesn’t exist, and the entry isn’t necessary - in fact, it shouldn’t even be there - the obvious solution is to launch your favorite editor as root and either comment out or absolutely remove the module reference.

Likewise for the ipv6 module.
ipv6 does exist, and loads, but unless you have an absolutely hair-raising, someone’s going to DIE, reason for running IPv6, it should be disabled on every machine and device on your network as it causes no end of problems.

Ultimately, what I did was to delete the last two lines of the modules.conf file, save it, and reboot.

No error messages, no interesting kernel states shown set in the kernel logs, and things work like a champ.

My advice: Delete the two lines on every R4R installation you have.

1 Like