Scan cannot find wifi


#1

Hi.

I just got my BrickPi and I’m using the raspberry pi 3 model B. I’ve gotten everything on the setup working so far except the WiFi, using this guide http://www.dexterindustries.com/BrickPi/getting-started/using-the-pi/setting-wifi/. I can currently access the Pi’s desktop using VNC. But when I go to Wifi Setup and press Scan for networks, nothing happens. Nothing comes up.

I’ve tried using both a usb-wifi dongle and not using it.

I’ve also tried to do the process from the terminal, using this guide: https://www.raspberrypi.org/documentation/configuration/wireless/wireless-cli.md

When running sudo iwlist wlan0 scan, I get a view of all the wifi networks I wish would pop up in the GUI before. Among those wifi networks, I can see my own in the terminal window. After this, according to the guide, I ran sudo nano /etc/wpa_supplicant/wpa_supplicant.conf, and tried changing the network object to match my wifi setup with name, password, etc. After this I rebooted the pi, but still I do not get access to the internet and when running ifconfig wlan0, I get an inet addr:10.10.10.10.

What should I do to get the wifi working?


#2

Heya eliassvensson,

Which version of Raspbian for Robots are you using/ From the end of your statement, you’re showing up at 10.10.10.10; I think you’re using our Cinch, not Wheezy, version. Can you tell us what the name of the zip file you were using to burn the image?

Thanks! John


#3

I have the same problem. Also running a new BrickPi with the Raspberry pi 3 model B, and the SD card as it was supplied (with Cinch). The wifi setup doesn’t work, so I can’t update the firmware, so nothing else works.


#4

I’m sorry this post has sat for so long @dthomas.

So you’re running a BrickPi3, Raspberry Pi Model 3, and Cinch. Do you have the Dexter Industries wifi dongle plugged into the Raspberry Pi? When you power it up, do you see lights begin to turn on inside the wifi dongle? Are you seeing the power and ACT lights on the Raspberry Pi blink?

One thing to check: when testing and setting up for the first time, we would recommend powering using batteries AND USB power to make sure that power isn’t an issue for the Pi. When the power runs low, the wifi dongle might not turn on.


#5

Thanks for the reply. In the end I gave up on Cinch and downloaded the BrickPi3 drivers on a Raspbian SD card. Part of the problem may have been that you shipped an old (2016.10.14) version of Cinch with the BrickPi. I still have wifi problems, but now a different issue for which I’ll start a new post.


#6

In theory, if you have Cinch, you are not meant to set wifi up. Your best bet to update this card is via an ethernet cable. With Cinch, the wifi is dedicated to the Pi being an access point. It can’t do both, being an access point and giving you access to the Internet.
If you have Cinch:

  1. you don’t depend on local networks to talk to your robot.
  2. you will need an ethernet cable to connect to the Internet. You can either plug it in directly in a router for the duration of the DI Update, or to a laptop that is sharing its internet connection.
  3. Once the update is done, you go back to mobile mode and a closed network.

Does that clarify things a bit?

Cleo