Scratch and Troubleshooting Crash After SW Update


#1

Hi! Running into some issues with Scratch and Troubleshooting crashing after I updated the software and firmware for our GoBox mission. Tried reinstalling the software from the VNC using the Software Update but not luck. The GoPiGo works fine (as far as I can tell). I can ping through Terminal on my Mac and on the LXTerminal on the VNC.

But for some reason when I open Scratch, the window opens and immediately closes. Same with Testing & Troubleshooting on VNC.

Any suggestions?

Thanks,

Gary


Motion sensor not showing in Scratch[SOLVED]
#2

Hello Gary,

Sorry you’re having this issue. It happens if the Software Update didn’t go through properly. Here’s a way to get it back on its feet.

You have to open a terminal window (look at the top menu bar, there’s an icon that looks like a black screen - that’s the icon for the terminal)
Once it’s opened type in
./update_backup.sh
the leading ./ are necessary
Once you’ve done that, you can attempt the DI Update again.

Cleo


#3

Hi Cleo:

Thanks for the fast reply. I’m just getting back to this now. I tried typing the command into terminal and it says “No such file or directory”…is there a chance that I’m reading it wrong? I typed it in a couple of different ways:

./update_backup.sh (return) the leading ./ are necessary
./update_backup.sh the leading ./ are necessary

I know that terminal commands have to be precise, so can you tell me how I am not implementing the command properly? Thanks! Gary


#4

Whoops. Strike that last post. I mistakenly went into Terminal on my Mac and not the VNC.

I typed in the command and then reinstalled the update but I am still having the same issue. I can connect wirelessly with the GPG and the terminal commands and software installs seem to work fine. But Scratch crashes on startup.

There was one note in the window while I was working on the terminal that said “xlib extension “RANDR” missing on display “;1.0”,” Could that be the issue? Or do you think that the SD card might be corrupted?

Thanks!

Gary


#5

When you start Scratch at which point does it go wrong?
Do you see:

  1. The scratch icon on the desktop
  2. The scratch controller window where you can select which robot
  3. When you click on start programming, is there a terminal window that starts up?
  4. The scratch interface comes up

How far can you get in those steps?


#6

I see the scratch icon on the desktop. When I open the program, the window partically opens and then abruptly closes. That’s as far as it gets.


#7

Can you just confirm that it’s this window that crashes ?


#8

That’s not it. I think it’s the black window behind it that doesn’t open.


#9

Ok thanks. I can’t investigate it at this very moment but I’ll come back to you as soon as I can.
Sorry about the delay


#10

No worries. Your support has been fantastic! I really appreciate the help!


#11

Ok, thank you for your patience. I’m now in front of a real screen instead of a cell phone.

Could you do the following and tell me what you get

  1. Start a terminal window (on the Pi :wink: )

  2. type in the following:
    cd Desktop/GoBox/Scratch_GUI

  3. Type in
    ls *.py

  4. Type in
    python Scratch_Start.py

  5. You will either get the Scratch for Robots window, or an error message. If you could get a screenshot of the error message (even if it’s a photo taken with a cell phone), it will help me a lot.

Thanks again for your patience.
Cleo


#12

OK. I got the error message. Here is a screenshot. I highlighted it to help make it a little easier to read.


#13

great!
Well not great as it’s not working but at least I know how to fix it.

Again in the terminal window - brace yourself there’s lots of meaningless typing :

sudo apt-get install python-wxgtk2.8 python-wxtools wx2.8-i18n --force-yes -y			
sudo apt-get remove python-wxgtk3.0 -y

I have no clue how your SD card could have ended up with this issue. I’ll investigate on the why later. First let’s get you back up and running.

Cleo


#14

I typed in the commands a few times but no luck just yet.

Here is a screen shot of the reply. Something that I first run sudo dpkg --configure -a to correct the problem?


#15

Ah, yes. It happens once in a while if an update goes wrong. Do run the suggested command as is.


#16

I’m sorry, I think you lost me on that one. I guess I’m not sure I understand how to run the command as is… I typed in the commands and after I entered them, I got the error message and nothing else happened. Is there something I need to do to over ride it?


#17

My apologies.
I was referring to the suggested command in the screenshot you sent here.

sudo dpkg --configure -a

It will allow the Pi to figure out on its own what went wrong and how to fix it.
Once you run that command, you will be able to retry the two commands from before

sudo apt-get install python-wxgtk2.8 python-wxtools wx2.8-i18n --force-yes -y
sudo apt-get remove python-wxgtk3.0 -y


#18

Oh, gotcha! I’ll give it a shot and report back.


#19

Ok. Both commands ran but each came back looking for a package. Is that the intent? Or are we missing something?


#20

The second one is fine. We’re trying to remove python-wxgtk3.0 and it says it can’t find it. So that’s fine.
However the first one is supposed to find it.

The uploaded screenshot is pretty small and I have bad eyes, being over 50. I’ve got to squint but it seems you missed a dash in wx2.8-i18n
sudo apt-get install python-wxgtk2.8 python-wxtools wx2.8-i18n --force-yes -y

And I’m sorry you’re experiencing this issue. It’s kinda challenging as the commands to be entered have to be very precise with no margin for errors. Worse than Shakespeare.