Scratch screens look different


#1

Per http://www.dexterindustries.com/BrickPi/getting-started/5-controlling-the-brickpi/

It says I should get scratch for robots window, but I do not get these screens as listed on these web pages.

I am not sure why. I am not sure how to load example programs on to my robot to check motors and basic features.

I can see wifi and ethernet files on my robot.


#2

Hi jondhager, are you using Raspbian for Robots or are you using your own image? Can you attach a screenshot of your desktop for us?


#3

I am using the files and loads that were included in the package I bought from you all I did load tools like VNC, Putty, etc. I have BrickPi package.


#4

Ok, can you post a screenshot of what your scratch looks like, and a screenshot of your Rasberry Pi Desktop?


#5

here is pic.

I am still poking away at trying to run a program on the robot.

Is there a way to tell if a program is loaded into the robot and running?


#6

I’m not seeing a pic? I think it didn’t transfer correctly. Would you mind trying again?


#7

File was to large last time. Try this one in power point


#8

Hey Jondhagar, I think I understand what happened. YOu have an older version of Raspbian for Robots. We made some large changes back in November of last year; yours looks like it was installed pre November 2015.

Your best option is to follow these instructions: http://www.dexterindustries.com/howto/raspberry-pi-tutorials/install-raspbian-for-robots-image-on-an-sd-card/

And download the latest version of Raspbian for Robots here.


#9

Thanks guys for the help and responses. Updating software to latest configs made things better. I would suggest you more clearly state that this is a must do on updating software (I did not buy my system that long ago). I have a couple more questions that may be related to this update and screens

  1. when I run wpa-gui I can not see any wifi nets. I can see them if I run ifconfig -all in command window or look on the PC Wifi info (I am running Windows 10). I can only see wlan0 on wpa-gui. I have run IR receiver setup and disabled. Not see networkds means I can not connect to the dongle. I have reboot everything several times including routers and looked in posting (all are older). I am tried using TP-link (router), verizon Jetpack (a broadband cell device router device) and apple Iphone hotspot all with no luck. Suggestions?

  2. I now see in the new software an app “DI software update” Should I run this too since I just down loaded new software? This instructions on its use are not clear either.

Thanks again. I am making progress when real work does not get in the way. :slight_smile: