Sd startup configuration


#1

I can access my sd card for brickPi … the image for which I downloaded from you…ok via ssh command line and wifi.

However, if I plug the card into my normal raspi setup (with proper power supply, hub, network, mouse, keyboard), it comes up with Dexter background and using all the cpu.

I would prefer it to come up in command line mode and to have the ability of then using startx.

How can I correct this?


#2

Tom, Glad to hear it’s working. I’m not sure why it’s running at 100%; are you connected to it via SSH and or VNC as well? That could be driving up the power usage.

To get it to boot to the command line, have you tried running raspi-config? That let’s you change “boot_behaviour” and you should be able to boot up to command line rather than to desktop.

Let us know if that works.!


#3

Sigh. I ran raspi-config so that the system started in command more. But when I issue the startx command, the brickpi background is displayed and the system cpu is saturated. Two pids both called pcmanfm are each taking 44%.

What is pcmanfm?

So I killed both processes, shutdown and restarted. Both processes appeared when I restarted. Clearly some demon is initiating these processes.

So how do I fix this? Is this the way you raspi distribution is meant to work? …maybe with only one psmanfm?

I may try to burn another sd.


#4

I’m not sure why it’s running two pcmanfm’s. These are the file manager programs from Debian. On restart, if you’re just running the command line and nothing else, are you also running VNC?


#5

I burned a new sd and set it up with no problem. I must have somehow corrupted the old sd card.

I can now access things in the gui as I expected.

Incidentally this new image has a different behavior when red logout button in the lower right-hand corner. It now gives shutdown and other options. So this new image is not the same although you date it as 2013.07.27. The image I was using is dated on my Mac as Sept 25.

Have there been been changes to the image after 2013.07.27?

Thanks for your interest

Tom


#6

Hey Tom, glad we got it sorted and it’s now working. No, the image really hasn’t changed since July. We have a few changes in mind we’ll be working on over the next month to make it easier to setup. Thank you for your patience and working through this issue!