[SOLVED] Arduberry - stk500_recv() - programmer not responding


#1

Followed the web directions and the readme file, its a Ri3 with a touchscreen here is the error message.
I set the board to uno the port to both Serial and AMA0 same result, programmer is set to Raspberry Pi GPIO

Arduino: 1.6.0 (Linux), Board: “Arduino Uno”

Sketch uses 1,030 bytes (3%) of program storage space. Maximum is 32,256 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2,039 bytes for local variables. Maximum is 2,048 bytes.
avrdude: stk500_recv(): programmer is not responding
Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

This report would have more information with
"Show verbose output during compilation"
enabled in File > Preferences.


#2

My mistake was using the menu vs Ctrl-Shift-U seems to be working ok now :wink:


#3

Hi @mhjorleifsson,

I’m glad you’ve found a solution on your own.


But your remark doesn’t seem to match with the reality.
And I mean about this phrase of yours : using the menu vs Ctrl-Shift-U.

In order to upload to your ArduBerry, you need to setup:

  1. The appropriate port from Tools -> Port - in my case it’s /dev/tty/AMA0.

  2. The appropriate programmer by selecting Tools -> Programmer -> Raspberry Pi GPIO.

After that you can upload to your ArduBerry by:

  1. Pressing the CTRL-Shift-U key.

  2. Or by selecting File -> Upload Using Programmer.

Is this what you have been doing, or did you encounter another issue with the IDE?
Can you give us more details?


Thank you!


Raspberry Pi 3 does not communicate with Arduberry
#4