[SOLVED] BrickPI doesnt work


#1

Hi,
My Brick PI stopped working.

Using python sample scripts raspberry pi hangs and I have to kill process.

I checked firmware and got “Firmware version is: None”

I decided to upgrade firmware to solve the problem.

After upgrading I got the same results.

Any help please ?

Below EV3-Firmware_Check output.

sudo python EV3-Firmware_Check.py
sudo: unable to resolve host (none)
Trying to communicate with firmware.
PASS: Serial line setup.

Setup sensors returns: -1
Checking Firmware Version of BrickPi.
Firmware version is: None
DOH! Please update your firmware to run EV3 sensors!
You should be able to run NXT sensors, but not EV3 sensors.


#2

Sure, first a few quick questions:
How did you upgrade the firmware?
Can you attach a picture of the BrickPi you’re using? Where did it come from?

Thanks Marcin! John


#3

I’ve bought BrickPi Advanced on October 5, 2014 from your site.

I used it a few months ago with my EV3 so I’m sure it worked correctly.

Yesterday I’ve upgraded firmware using avr programmer based on your instruction without any problems.

I know that both avr microcontrolers on Brick PI works because I can connect to them using avrude.


#4
Yesterday I’ve upgraded firmware using avr programmer based on your instruction without any problems.

Except that it doesn’t work now I guess? It looks like you would have an older BrickPi Advanced model if you bought it back in 2014.

Also, are you using the latest version of Raspbian for Robots? One thing to check is whether there is data moving on the serial lines or not; do you have access to a logic analyzer we can place on the serial lines and check if serial information is moving?


#5

Yes. It still doesn’t work.

Yes. I’m using the lateste version of Raspbian for Robots.

If you red my topic http://www.dexterindustries.com/topic/brickpi/ you can see that on August 7, 2015 I’ve upgraded BrickPi and got reply :

“Firmware version is: 2
GREAT! Firmware is up to date!
You should be able to run EV3 sensors!”

It means my Brick Pi supports EV3 and it worked on August 7, 2015 .

Only one difference is that I use the latest version of image file.

Did you chane something in software that latest rasbian image doesn’t supports older BrickPI hardware ?
If yes can I got older versio of imagefile ? Make it sense or not ?

Can I useUSB-to-Serial converter to monitor serial lines ?

In attached file there is image of my BrickPi.


#6

Additional info:
I’ve tested it with two RPI but the same SD card.

With both I got the same results.


#7
Did you change something in software that latest rasbian image doesn’t supports older BrickPI hardware ?
Yes!

First, make sure you’re using a version later than Nov 2015. The latest is here: http://www.dexterindustries.com/howto/install-raspbian-for-robots-image-on-an-sd-card/

Second, check the communications lines. We’ve seen this before, but in the latest image we setup an option to switch to an IR receiver. This has caused folks issues. Can you look at this tutorial and let us know if it solves the issue: http://www.dexterindustries.com/howto/enable-or-disable-brickpi-communications/


#8

I’ve disabled ir receiver and my Brick Pi works OK.

Setup sensors returns: 0
Checking Firmware Version of BrickPi.
Firmware version is: 2
GREAT! Firmware is up to date!
You should be able to run EV3 sensors!

PS.

  1. Can I disable and enable IR receiver using commandline ?

  2. If I buy new Brick PI I will have to disable IR receiver too ?

  3. What are main differences between my OLD Brick PI and the new one ?


#9

Marcin, great! Glad to hear it!

PS.

  1. Yes! But once you set it, you shouldn’t need to do this.

  2. No. If you are using the same image sd card, you shouldn’t need to. If you use a new image, disable the software again.

  3. Are you comparing the BrickPi+ vs BrickPi Advanced?