[solved] BrickPi No Longer Functioning


#1

I would like to request an RMA for a defective BrickPi logic board. The BrickPi board was functioning properly and for some unexplained reason,
it’s no longer driving the Lego NXT kit motors.

No modifications were made to the Raspberry Pi / BrickPI robotic device or to the Scratch example code
prior to the BrickPi board malfunctioning. I just purchased and replaced the Raspberry Pi computer and unfortunately, the BrickPi is still not controlling the
Lego NXT motors using the sample BrickPi example code. At this juncture, the only other device that needs to be replaced is the BrickPi board.

Thanks,

-Paul


#2

Sorry to hear about this Paul. I have a few quick questions for you:

  1. Are you using the latest DI Image Raspbian for Robots? If you’re using an SD card we sent you, what date is on it? Were you able to connect properly?
  2. Have you run the basic motor test on BrickPi? Have you modified this program in any way?
  3. How are you powering the BrickPi? Are you powering via the USB Raspberry Pi Power Supply?
  4. Can you please attach a picture of the BrickPi setup.
  5. Where did you purchase the BrickPi and when?

Thanks! John


#3

John,

Thank you for responding to my posting. I have resolved the issue with the BrickPi.
The GPIO controller on my original Raspberry Pi 2 board must have been damaged. After
replacing the PI, I am now, once again, able to control the NXT motors with the BrickPi board.

I’m looking for docs detailing the procedures for outfitting a BrickPi robot with a
Xbox controller wireless USB receiver and I was wondering if you happen to know where
I could find relevant information for configuring the BrickPi / Raspberry Pi2 with the
USB receiver?

http://www.amazon.com/gp/product/B00ZB7W4QU?psc=1&redirect=true
http://www.amazon.com/gp/product/B00VB2UT3O?psc=1&redirect=true

Thanks,

-Paul


#4

This is great news that the BrickPi is working. Thanks for letting us know. Can you tell us more about the Raspberry Pi though, and what might have happened?

We worked on a PS3 controller for the GoPiGo. Setting it up and getting it going with Python or C is pretty trivial to port (and we would love a pull request if you do it). It’s a little tricky but Karan did a great job getting it going: https://github.com/DexterInd/GoPiGo/tree/master/Software/Python/Examples/PS3_Control


#5

I wish I had an explanation for the issue with the GPIO controller. It’s possible a device providing power to the pins was accidentally
either plugged into the GPIO controller or inadvertently connected to the wrong pins on the PI.

I appreciate you sending a link to a doc for outfitting a GoPiGo with a PS3 controller. I’ll let you know if I ever get an Xbox One or Xbox 360 controller functioning with the BrickPi.

Thanks again for responding to my messages and for your willingness to assist me with resolving my issue.

-Paul


#6

Paul, no problem! Sorry for the troubles!