[SOLVED] BrickPi+ Not Booting Or Booting With No Icons


#1

Last Christmas I was given a BrickPi+ to use with my Raspberry Pi B (Model 1), but have only recently got round to using it. When I came to use it, I realised that the card had not been purchased, so ordered a copy or Raspbian For Robots from the Dexter Industries store. After shipping to the UK, I tried it with my setup and it worked fine.
I then plugged in a WiFi dongle to set up the WiFi features on the OS. On my other operating system of normal Raspbian, this shuts down the computer and reboots it. This time it just shut down and refused to reboot.
I have tried all of the advice on the Dexter Industries site and other help websites, but nothing seems to work. To list some of the things I have done:

  • Booted with the hat on and Raspbian as the OS to factor out the hat being the problem;

  • Booted on Raspbian For Robots without the hat on to factor out there being a blockage between the OS and the hat;

  • Flashed the newest version of Raspbian For Robots onto the SD card. This caused the Pi to initiate an auto-shutdown upon boot;

  • Dug the initial version of Raspbian For Robots that was on the card (2016.10.14) off the same website the new version was assertained to and flashed that onto the SD card. This time the Pi booted, but it appeared to have no icon packs loaded or the locations of the applications pre programmed onto it.

  • I then tried all of the above on a different SD card with a higher storage capacity, and that too failed.

I have spoken to someone else who also owns a BrickPi+ and runs it off a newer version of the Raspberry Pi, but still uses a WiFi dongle and said that it has never happend to him and that it shouldn’t happen. He is a software developer by trade so I trust his words.

I am at a bit of a loss for what to do, so thought I would come here to see if any fellow users could offer any advice. Thanks a lot!


#2

Interesting. I have a Pi Zero and the wifi dongle makes it quit, however it does boot up if it was put in before startup. This makes me think that some Raspberry Pies :wink: don’t like WiFi Dongles. My suggestion would be to get a Raspberry Pi 3. It has built in WiFi and also works with WiFi dongles. Of course it might be good to hear what others have to say about this matter too.

Also how many amps does your power supply put out? It could be it isn’t getting enough power.


#3

Hi @graykevinb, I use the standard power supply that came with my Raspberry Pi. I think the output on that is 5V / 2A.
It has always worked fine with the WiFi dongle I use (WiPi) that is a specific WiFi dongle for Raspberry Pi’s.


#4

Hi @Harry_P,

I think you’re encountering something similar with what I (and a majority of users) have already encountered.

Could you tell us if you still have a black foam attached to your BrickPi+. This black foam is electrically conductive and can make the Raspberry Pi to auto-shutdown.

Thank you!


#5

Thanks @RobertLucian. I did not know that I will remove it when in use. I have just managed to solve the OS issue.


#6