[SOLVED] BrickPi3 Robot not working when the Ethernet cable is removed

brickpi3

#1

Right now i’m working on a project for school using the BrickPi3, i’m programming using python but i think i’m doing something wrong.
Whenever i run the program it works fine, but when i remove the ethernet cable from the BrickPi gets stuck on code.
For example when i run ‘LEGO-Motors.py’ and i remove the ethernet cable the robot keeps it’s motors on, when the ethernet kable is plugged in the touch sensor and the motors work exacly as they are supposed to. Am I running my python code the wrong way?
i use the commands ‘cd ~/Dexter/BrickPi3/Software/Python/Examples’ and then ‘python LEGO-Motors.py’.
I assume the BrickPi is supposed to work, when not connected to a computer with an ethernet cable right?


#2

If you’re using Ethernet for your LAN connection for SSH, when you unplug the cable, the connection will fail. You could try using WiFi to have a wireless LAN connection. I can confirm that the BrickPi3 works fine without the Raspberry Pi having an Ethernet connection.

If you need to run a program without keeping a terminal session active, you can run the program with & at the end of the command, e.g. python LEGO-Motors.py & Stopping the program will be more complicated than just a simple Ctrl+c.


#3

Thank you for the reply.
The ‘&’ symbol did the trick It was important than the robot could run a python file when it was not connected to a computer/monitor at all. Because i’m trying to move the robot with a Unity app over bluetooth, on a smartphone.