[SOLVED] Can't detect GrovePi on Raspberry Pi 4

Hello I’m a student and want to get the GrovePi hat working on a Pi4. I’ve tried to follow this setup guide but after i run “sudo i2cdetect -y 1” I get the following.

I also ran the troubleshooter.

log.txt (3.0 KB)

Solution TLDR:
I used the image from cyclicalobsessive in this post and followed the detailed setup guide as linked above.



What operating system are you using on what version of the Pi-4?

Did you remember to turn on i2c by running raspi-config?
sudo raspi-config from within a terminal window.

Select “Interfaces” and make sure SPI and i2c are turned on.

Then give it another try and let us know what happened.

1 Like

I just enabled SPI and rebooted but no luck. I2C was enabled and I used the Raspbian image from The Raspberry Pi site because the expirimental build didn’t boot for me.

PRETTY_NAME=“Raspbian GNU/Linux 11 (bullseye)”
NAME=“Raspbian GNU/Linux”
VERSION=“11 (bullseye)”
SUPPORT_URL=“RaspbianForums - Raspbian
BUG_REPORT_URL=“RaspbianBugs - Raspbian

1 Like

That is probably the problem - Try a prior PiOS Buster image such as:


But actually, I know nothing about GrovePi or RPi4 - so disregard this post.


THAT is very odd.

If you were me and I was you, I would drop everything and solve this problem. Raspbian for Robots (Buster), should boot. If it doesn’t there are other things going on that need to be examined. . . .

I have a Raspberry Pi-4, 4 gig, and that image, (literally, that image), has been booting for me all day long.

BTW, WHICH Raspberry Pi-4 do you have? There are reports of things not working on the Raspberry Pi-4, 8 gig versions that go beyond simply booting.  I don’t have one so I cannot test with it.

Do you have any other Raspberry Pi hardware, (like a Pi-3) that you can try?


This is the screen I get when I try to boot the expirimental build.

I will try the solution cyclicalobsessive proposed as above and see how that works.


BTW, did you reboot after installing the GrovePi software? The install changes some of the boot parameters (such as enabling I2C ) in cmdline.txt which will not take effect until a reboot.


Yes I have rebooted every time I changed something.


I am going to download this image and try it on my own 'bot.

This will take a few moments - “please stand by. . .” :wink:

I’m going to flash a fresh SD card, plug it in, and try to find out what the problem is.



It looks like we’re both getting a “crash” :wink: course on the GrovePi!


Well at least it’s consistent, I’m setting up using the older Buster PiOS I’ll come back on you for that.


AND they all seem to be Pi4 as you predicted!

1 Like

You can try it, but if the release date is earlier than 2019/12/12, it may not work either.

You work your end, I’ll work mine, and we’ll meet in the middle.


I have great news, I downloaded the image from cyclicalobsessive and followed the setup guide and it worked like a charm.


The blinking light test also works.


Cool beenies!

Total props for @cyclicalobsessive!!

I still want to know what the deal with Raspbian for Robots is. . . .


Yeah I have absolutely no clue maybe a staff member can explain. Anyways thank you @cyclicalobsessive and @jimrh for your help!


On a similar topic. . . .

I don’t know what the deal here is, but - for absolute CENTURIES the GrovePi was a rusty derelict hulk that nobody talked about.

Now, in the last six months or so, GrovePi has come outta the woodwork!  So, what’s happening?  Has someone started teaching a Robots101 course somewhere that has a hard dependency on the GrovePi?

Not that I’m complaining mind you. . . .

1 Like

What I know is that my school suddenly bought a lot of Raspi’s with sensors for students to use for IoT innovations. I’ve also read on a lot of stores where teachers are giving reviews with the same story. That may be an explanation.



Now, all we have to do is get 'em using the GoPiGo-3!!

This is “Charlie” - my GoPiGo-3 'bot. The thing on his back is a 500gb SSD and the dip switches allow me to select which O/S of several to boot.  The last dip switch, (#5) lets me choose either a 32 bit or 64 bit kernel.

Lots of fun with this beastie.

@cyclicalobsessive and @KeithW have been Boldly Going where No GoPiGo Has Gone Before - using ROS, LIDAR, and all kinds of fancy goodies to turn their 'bots into MONSTER 'BOTS!!

We have a lot of fun here.  Not to mention that us poor sods can use all the GrovePi help we can get!  Especially from people who are actually USING it. . . :man_facepalming:


I just tried it and it worked wonderfully on my system.

One thing you may want to try is updating the Rasberry Pi-4’s internal firmware. Yours may be a bit old.

There’s a trick with the Raspberry Pi Imager that can be used to update firmware - instead of installing an operating system, you tell it you want system tools and it will help with firmware updates.

If you get a free breath, try it and see what happens.