[SOLVED] DexterOS: Unable to connect to BrickPi3


#1
  • Downloaded dexterOS ver. 2.2.0 and unzip
  • Used win32diskImager to burn image to sd card (32 GB)
  • SD card in Brickpi3. Connected with Ethernet cable. Using USB Power Supply.
  • Red LED is On. Green LED on Pi is blinking.
  • Green LED on BrickPi Card is ON. Power is set to Off.
  • When trying to get SSH connection using ssh pi@dex.local I get the error: The host is unknown.
  • Ping dex.local does not respond.
  • http://10.10.10.10:8001 . Answer: page does not exist.
  • Try starting with a monitor, keyboard and mouse. Monitor shows a lot of info. 2 errors detected
    • Failed to start dhcpcd on all interfaces
    • Failed to start Configure Bluetooth Modems connected to UART

Last lines on monitor are:
Raspbian GNU/Linux 9 GoPiGo tty1
GoPiGo Login:

If have tried User: pi Password: robots1234 but they don’t work.

  • Lookup to the DHCP client list on my router: Host: GoPiGo ip: 192.168.1.105.
  • Ping GoPiGo don’t respond. 192.168.1.105 does respond.
  • Reburn the image. The result is the same

Can anybody tell me who to continue?


#2

Hello @egonjorg

There seems to be a bit of confusion here.
DexterOS is meant for the GoPiGo and not the BrickPi. To use the BrickPi and be able to ssh into dex.local, you need to have Raspbian for Robots.

https://www.dexterindustries.com/raspberry-pi-robot-software/

Could you download that and try again?

Cleo


#3

Thanks for quick respond and help.
I have downloaded Raspbian For Robots.
I’m now able to use the desktop. Still I can’t use ssh. Login problems.
Ssh does not work with Hostname: dex.local. It says that the host is valid but don’t have anything to respond to me.
I have to use the IP address. My router confirm the name dex though.

By the way I got the dexterOs following the links to the software starting from the brickPi getting started.
Is it not possible to use DexterOS with the BrickPi? If not You should state that on the download page.
Egon


#4

@egonjorg
I’m glad you’re up and running now!

depending on how your network is configured, sometimes dex.local isn’t recognized by default. If you’re running a mostly Windows environment, you could try entering dex/ in the browser URL field. If that doesn’t work, is Bonjour installed on your system?

As for getting the DexterOS download while following the BrickPi instructions, I would very much appreciate it if you could detail how you got there? Obviously there’s a spot that we think is clear but is confusing for others. I would dearly love to remove the confusion!

Thanks
Cleo


#5

I got an eye opener! dex/ in my browser and the startpage show up. I have used putty to open a connection. This was unsuccessful.
I haven’t tried to connect any Lego parts yet but the OS is working.

Here is how I get to the dexterous in the first place:
When I downloaded the software I started with this page:
https://www.dexterindustries.com/getting-started-2/

Clicked on The BrickPi. In the Getting started I clicked on:
https://www.dexterindustries.com/BrickPi/brickpi3-getting-started/brickpi3-getting-started-step-1-assembly/

Here I click on + 1. Insert the SD card.
I read all the text and at the buttom of the page I click on + Download and use our software with your own SD card.
That opened the following text:
If you want to download and use our modified Raspbian image on a dedicated SD card we have step by step instructions on installing the Raspbian for Robots Image to an SD Card here for both Mac and PC<https://www.dexterindustries.com/howto/raspberry-pi-tutorials/install-raspbian-for-robots-image-on-an-sd-card/>.
When I click on the link I come to this page:
https://www.dexterindustries.com/howto/install-raspbian-for-robots-image-on-an-sd-card/
Here I Opened the + Using a PC
This showed the following text:
First, download a copy of the image
· DexterOS: download here.<https://www.dexterindustries.com/download/dexteros>
· Raspbian for Robots: from Sourceforge here<http://sourceforge.net/projects/dexterindustriesraspbianflavor/>.
· Cinch: from Sourceforge here<https://sourceforge.net/projects/dexterindustriesraspbianflavor/files/Cinch/> or Google Drive here<https://drive.google.com/open?id=0B0WChwP4CnLBVlY2MXR2cFA1a3M>.
Here I thought: there is 3 possible OS which I can choose free. So I choose DexterrOS.

End og story.

Is the only OS Raspbian-for-robots?
I miss an explanation of the pros and cons for the 3 OS.
I don’t know anything about Cinch. What special with this OS?

Still I don’t understand why the dexterOS couldn’t work on the RPi. It loads, and it ran, but I could not connect to it?

You don’t have to answer these last questions from an newbee. I’m just wondering and I’m sure to get wiser as time goes by.
Thank You for helping.


#6

Thank you @egonjorg
I’ve added a note next to DexterOS that it is only for GoPiGo robots. Hopefully this will help others in the future.
Very kind of you to take the time to write it all out!

For the BrickPi3, the only OS is Raspbian for Robots, or its naked version Raspbian (but then you have to install the BrickPi libraries manually)

Cinch is/was a version where you could connect directly to your Pi without having to set it up on your local WiFi. It hasn’t been updated in a bit because most of the people who needed it are now using DexterOS. However Cinch could also be used for BrickPi.

DexterOS only works with the GoPiGo. It only comes with the GoPiGo libraries and is tightly coupled with that robot.

I hope this clears up the confusion?

Cleo


#7

Thank You. Everything is working now.
One last question in this session:
Next step for me is programming the BrickPi in Python.
I have studied some of the examples and the projects codes.
Where can I find tutorials for writing Python code for the BrickPi3?
Egon


#8

We don’t have tutorials per se but you can get the info from the examples listed here:
https://www.dexterindustries.com/BrickPi/brickpi-tutorials-documentation/program-it/python/