[SOLVED] Distance Sensor and Servo problems


#1

I’m running into some issues with a classroom set of GoPiGo3’s and I’m hoping someone can help.

All five robots have the servo plugged into Servo Port 1 on the left side and the distance sensor plugged into the IC port on the right of the robot (on the corner by Servo 2 and Analog Digital 2).

In Bloxter 1.0.1 we can get a distance reading from the sensor though it is finicky. I assume the sensor can’t measure distances outside of a certain parameter and errors out. There is no command in the version of Bloxter for turning the servo.

I’ve upgraded three robots to Bloxter 1.1.1. In this version we can’t get a reading from a distance sensor at all. Also, there are commands for moving the servo but we can’t get the servo to move.

This behavior is consistent from robot to robot.


#2

@jswann5726,
I’ll do my best to help out.
First you are right, there’s a limit to what the distance sensor can read. It works best within 2m.

Bloxter 1.2 is out and has a servo fix in it. Did you try it?

Thanks,
Cleo


#3

Thanks for confirming my guess on the sensor.

I was unaware of the 1.2 update. That’ll be my next step. The robots are at school. We are out for inclement weather tomorrow and with the holiday weekend it will be several days before I can get back to this. Will report when I can.

Joe


#4

I needed to come in to school today so I’ve done a little testing. I’ve successfully updates two robots to 1.2. Logging in with the browser works as it always did but is EXTREMELY SLUGGISH compared to the previous versions of the Dexter OS. The pages take a very long time to load now. Driving the robot used to be responsive. Now it is not.

On the bright side, the distance sensors are working. The servo, however, is not.


#5

I’m sorry to hear you’re having issues with 1.2 especially with sluggishness. In our internal testing 1.2 is more responsive, not less.
Which browser are you using? And by any chance do you have a USB key inserted so we can get the logs and see to this issue?
I really don’t want a sluggish Dexter OS out there.
Cleo


#6

My robot assembly team named out 'bots after Sith lords. Here’s the logs from Darth Maul. I’ll send you logs from Vader later.

1_Flasklog_2017_06_14__19_04_05.txt (45.9 KB)
11_Systemlog_2017_06_14__20_17_46.txt (859 Bytes)
9_Flasklog_2017_06_14__20_31_48.txt (37.0 KB)
15_Systemlog_2017_06_14__20_39_12.txt (94.0 KB)
WiFi_Log.txt (27.9 KB)
9_Systemlog_2017_06_14__19_58_10.txt (142.4 KB)
13_Systemlog_2017_06_14__20_31_44.txt (90.1 KB)
14_Systemlog_2017_06_14__20_33_42.txt (108.4 KB)
12_Systemlog_2017_06_14__20_19_18.txt (147.1 KB)
6_Flasklog_2017_06_14__19_58_14.txt (120.1 KB)
7_Systemlog_2017_06_14__19_40_36.txt (76.6 KB)
10_Systemlog_2017_06_14__20_05_40.txt (257.1 KB)
3_Flasklog_2017_06_14__19_26_06.txt (283.4 KB)
7_Flasklog_2017_06_14__20_05_45.txt (125.2 KB)
8_Systemlog_2017_06_14__19_43_35.txt (149.6 KB)
6_Systemlog_2017_06_14__19_26_02.txt (290.3 KB)
2_Flasklog_2017_06_14__19_13_37.txt (214.9 KB)


#7

Oh, and Chrome. Tried it from Windows 10 and macOS Sierra.

Interestingly, from my Mac I could log into the robot’s wifi. I knew I had done this because the Dropbox icon had dimmed. However, then I went to bloxter.com it acted like I was on the online version. The info line at the top said I was connected to Darth Maul (PI only) and showed version 1.2. But the home page only had the two icons like you see on the online Bloxter. When I clicked on the coding icon it wanted me to choose between a GPG2 and a GPG3.


#8

Vader…

4_Flasklog_2017_06_14__19_18_55.txt (67.1 KB)
1_Flasklog_2017_06_14__18_17_52.txt (105.2 KB)
1_Systemlog_2017_06_14__18_17_45.txt (170.9 KB)
4_Systemlog_2017_06_14__19_17_48.txt (307.4 KB)
2_Systemlog_2017_06_14__18_29_31.txt (75.0 KB)
WiFi_Log.txt (205.9 KB)
3_Systemlog_2017_06_14__18_29_42.txt (209.4 KB)
1_Systemlog_2017_06_14__19_05_57.txt (741.6 KB)
1_Flasklog_2017_06_14__19_07_40.txt (260.4 KB)


#9

Bane…

3_Flasklog_2017_06_14__19_16_01.txt (14.0 KB)
10_Systemlog_2017_06_14__19_55_33.txt (859 Bytes)
6_Systemlog_2017_06_14__19_25_25.txt (855 Bytes)
12_Systemlog_2017_06_14__20_19_34.txt (3.5 KB)
4_Flasklog_2017_06_14__19_17_55.txt (10.0 KB)
14_Systemlog_2017_06_14__20_27_02.txt (3.4 KB)
6_Flasklog_2017_06_14__19_30_17.txt (71.5 KB)
8_Systemlog_2017_06_14__19_30_14.txt (106.2 KB)
WiFi_Log.txt (151.3 KB)
9_Flasklog_2017_06_14__20_28_56.txt (139.7 KB)
7_Systemlog_2017_06_14__19_25_36.txt (88.1 KB)
8_Flasklog_2017_06_14__20_20_26.txt (201.7 KB)
13_Systemlog_2017_06_14__20_20_19.txt (354.3 KB)
15_Systemlog_2017_06_14__20_27_47.txt (304.5 KB)
1_Flasklog_2017_06_14__18_38_15.txt (281.9 KB)
1_Flasklog_2017_06_14__20_21_02.txt (400.1 KB)
9_Systemlog_2017_06_14__19_33_00.txt (205.7 KB)
2_Flasklog_2017_06_14__18_58_13.txt (919.5 KB)


#10

My robot assembly team named out 'bots after Sith lords.

Really??? Really??? I used to be known as DarthCleo although someone started using that exact nickname after I dropped it… So yeah, I :heart: your kids :slight_smile: Great taste!

I’m going to take a look at the logs now. May I ask what version you had before the update? And would you mind re-trying the update ? Something went wrong, and a second update may fix it.

ETA: make sure you do a hard reboot after the update is finished by pressing the power button.

Thanks
Always 2 there is …
Cleo


#11

Also, the kids are now supposed to go to http://mygopigo.com and not http://bloxter.com

This is new with 1.2 , but the system should have taken them to mygopigo.com automatically if they enter the wrong address

Cleo


#12

Some were at 1.0.1 and others at 1.1.1. Not sure who was at what. I had thought the boys had them all at 1.1.1 but found out later they hadn’t finished that all the way through.

So do I just put the updater on the flash drive and let it update 1.2 with 1.2? Or would it be best to just wipe the SD card and put a clean copy of 1.2 on it?


#13

Trying Darth Maul again…


#14

Yes, please go ahead and update 1.2 with 1.2 and let me know how it goes. The fact that it says (pi only) means the firmware didn’t flash properly.


#15

Done that. Back to where I was.


#16

So same issue, huh? You have a gopigo3 and a pi3, or some other combination?

Would you mind doing it again but make sure to have an empty USB key (or at least empty the Logs folder) then send me just those logs? That way I’ll know for sure I’m looking at the logs of the update. Sorry for the extra work

Cleo


#17

Happy to do it. By the way, site responsiveness is very snappy now. Could be because I am at home now. Could be that a restart after the trip home fixed that issue. Also, I assume the program in the screen shot is sufficient to get the servo to move.


#18

And here’s the logs.

WiFi_Log.txt (20.2 KB)
1_Flasklog_2017_06_14__20_55_36.txt (71.5 KB)
1_Systemlog_2017_06_14__20_55_27.txt (160.7 KB)


#19

Hmm, those logs show you’re up and running. Is that right?

As for the servo, you are correct, that is enough to move the servo to position 45.
If it doesn’t react there are two possibilities.

  1. the servo is already at position 45. So just try another number to eliminate this possibility.
  2. the servo is connected the wrong way. Does the servo jitter when you power the GoPiGo? (it should)

Cleo


#20

Yes, all but the servo seems to be working correctly now. It drives responsively and gives me distance measurements.

On the servo, I’ve been trying 1, 2, and both as well as different numbers. It does not jitter.

On a different thread, I thought I’d try downloading a full copy of 1.2 and putting it on a spare SD card. I downloaded a ZIP file. Extracting that gives me a CPGZ file. Extracting that gives me a ZIP file. Extracting that gives me a CPGZ file. And on and on and on…