[SOLVED] Dust Sensor goes awol after 20+ hours

grovepi

#1

Running the Grove Dust sensor of a Grove Pi board.

Works a treat, except it goes awol after 20+ hours. Not exact times but fairly consistent. Can’t pin it down to a exact cause. All I get from the sensor is error code 121.

Grove Pi board has latest firmware. (Dust sensor wouldn’t work without update)

Have to call avrdude to reset something otherwise a reboot wouldn’t fix it. Only a power pull. I’ve got a number of these sensors and boards - all do it.

Any ideas?

Thanks


Python Sensor read failed after some time, i2C gone
#2

Hi @dexterindustries3,

I know that version 1.2.7 has lots of bugs and it’s still the official version. We have a beta we haven’t released yet and we should (but it still has to go through a couple of checks), but can you test version 1.3.0. It’s right here:

Can you try this out and let us know if the sensor still goes awol after those ~20 hours?

Thanks!


#3

Sure thing. I’ll test it tomorrow.

Can I ask quickly - is this a board firmware update or just code update to grovepi.py or both?
I’m asking as I’m (trying to) running a lean CLI build and the install process does like to install a heck of a lot of packages.

Thanks


#4

running this now

Wow - it installs ALOT of stuff doesn’t it?! nodejs , openjdk-8-jre , et al

What are these needed for?


#5

By default, it also installs everything you need for the GUI stuff. On this dev branch for version 1.3.0 there’s no way to only bypass GUI stuff, but there is an option on the main branch (just for the record), although this ain’t of much help for you.

If you are already sure you have the latest GrovePi library installed with the regular curl -kL dexterindustries.com/update_grovepi | bash -s -- --bypass-gui-installation, then you can just run curl -kL https://raw.githubusercontent.com/RobertLucian/GrovePi/fix/firmware-bugs/Script/update_grovepi.sh | bash -s -- --bypass-rfrtools and it’s going to take a lot less to install it.

Having said that, since you have an issue you are trying to solve, I suggest you do the basic curl -kL https://raw.githubusercontent.com/RobertLucian/GrovePi/fix/firmware-bugs/Script/update_grovepi.sh | bash installation. The idea is to keep things simple until you get more familiar with this.

Next, yes, the above command will update both the firmware code and the library code that runs on the Pi. Just make sure you update the firmware manually - there’s no case where this is done automatically since the Pi can never know for sure when a GrovePi is stacked on it.

Let me know how it goes for you.


#6

Okay - thank you.

Install done. Firmware updated to v1.3.0 - (checked via python) Rebooting my Pi. Lets see what happens over the next couple of days.

Thank you for your help. I’ll definitely be in touch to discuss getting the install process as lean as possible as I’m running this on a headless server and need as little extra stuff installed/running as possible.


#7

Looking very positive so far after a couple of days…


#8

That’s good. I guess this fixes the issue. I’ll leave this thread open in case something happens.


#9

I’d say this can be closed. Dust sensor has been working perfectly since putting the beta firmware on board. Tried a couple of devices - all gold.

Do you have an aspirational date for the beta being released?

Cheers. A


#10

I cannot come up with an exact date, but I can say very soon. Maybe this month.

And thank you for your feedback on the dust sensor!


closed #11

This topic was automatically closed after 27 hours. New replies are no longer allowed.