[SOLVED] GoPiGo3 Python installation issues (no pi user)


I’m trying to the Python library on my Pi running the latest version of Raspian (I had to reinstall today due to an issue). It’s a fresh install. As part of securing my pi (since it’s possible to ssh into it) I removed the default user ‘pi’.

When I run the install script I get the following output:

Updating GoPiGo3 for master branch with the following options:
Using "master" branch
Options used for RFR_Tools script: "--system-wide master --use-python3-exe-too --update-aptget --install-deb-deps --install-python-package --install-gui"
main: line 164: /home/pi/.tmp_rfrtools.sh: Permission denied
Installing RFR_Tools. This might take a while..
bash: /home/pi/.tmp_rfrtools.sh: No such file or directory
rm: cannot remove '/home/pi/.tmp_rfrtools.sh': No such file or directory
RFR_Tools failed installing with exit code 127. Exiting.

It seems that user pi is hardcoded into the install script (a safe bet 99.9% of the time :slight_smile: ). However, this leaves in a difficult spot. Is there a way to install the Python library without the pi user? If not, would it work if I created the pi user, installed the software, and removed it again? Or would the install be just for that user?

Worst case scenario I remake my pi account, I’m not planning on leaving my pi on at all times at the moment anyways.


Hello @prideaux74

You are indeed right, the installations are mostly hard coded to the pi user. However the installation will be done system wide. You can remove the pi user once it’s all installed.


Works like a charm, thanks so much for the help!

1 Like

Glad to hear it went well. Have fun with the robot!


This topic was automatically closed after 4 days. New replies are no longer allowed.