[SOLVED] How to upgrade Raspbian for Robots version to the latest?

r4r
update

#1

I thought I downloaded the latest version of Raspbian for Robots from here https://sourceforge.net/projects/dexterindustriesraspbianflavor/. But the easygopigo3.py in my source has different code content compared to github code here https://github.com/DexterInd/GoPiGo3/blob/master/Software/Python/easygopigo3.py.

I feel like I have wrong version and that’s why I am getting error message like ‘easygopigo3 doesn’t have the attribute init_distance_sensor’. Does someone know how I can correct this situation and can get the latest version of code?

Also I am a newbie for GoPiGo, so I don’t understand what’s different between Jessie vs Raspbian for Robots. Could you explain that what’s different between them?

Thank you!


#2

I just reburnt the SD card and then tried to run di_updates again since di_updates was broken and didn’t work for me. I remember I closed the updating window before it’s done since there was wifi down issue while running di_updates and then it started not working.

After reburn the SD card and then running di_updates, I see all the latest code. So my issue is resolved.


#3