[Solved] Impossible to connect the GrovePI + with the Raspberry Pi 4

Hi all, I’m totaly new with RAspberry Pi and all that stuff. I received some devices to work with for my internship.
I received a raspberry pi 4 and grove pi +. After few researsh i found how to setup software to be able to use the grove pi with the raspberry. So when I type this : sudo curl -kL dexterindustries.com/update_grovepi | bash
i got an error:

Processing dependencies for grovepi==1.4.1
Searching for scipy
Reading https://pypi.org/simple/scipy/
/usr/local/lib/python3.9/dist-packages/pkg_resources/__init__.py:122: PkgResourcesDeprecationWarning:  is an invalid version and will not be supported in a future release
Downloading https://files.pythonhosted.org/packages/b4/a2/4faa34bf0cdbefd5c706625f1234987795f368eb4e97bde9d6f46860843e/scipy-1.8.0.tar.gz#sha256=31d4f2d6b724bc9a98e527b5849b8a7e589bf1ea630c33aa563eda912c9ff0bd
Best match: scipy 1.8.0
Processing scipy-1.8.0.tar.gz
Writing /tmp/easy_install-6o0a556_/scipy-1.8.0/setup.cfg
Running scipy-1.8.0/setup.py -q bdist_egg --dist-dir /tmp/easy_install-6o0a556_/scipy-1.8.0/egg-dist-tmp-q65tjb26
/tmp/easy_install-6o0a556_/scipy-1.8.0/setup.py:482: UserWarning: Unrecognized setuptools command ('-q bdist_egg --dist-dir /tmp/easy_install-6o0a556_/scipy-1.8.0/egg-dist-tmp-q65tjb26'), proceeding with generating Cython sources and expanding templates
  warnings.warn("Unrecognized setuptools command ('{}'), proceeding with "
Error: 'pybind11' must be installed before running the build.

error: Setup script exited with 1

I already installed the ‘pybind11’ but still got the same error again and again.
I installed the new Raspberry Pi OS on the SD card.

Any help will be appreciate. Thank you

1 Like

Please read the following post carefully

HINT: Legacy Pi OS is the proven path to a successful GrovePi+ system


Absolutely true - every word of it.

If you installed Bullseye, you’re riding the fast boat to failure.  Download and try again with “legacy” Raspbian which is based on Buster.


Hello, I installed the legacy and everything seems to work.

Thank you so much.