[SOLVED] Lego Motors/Sensor don't work!


#1

Hello,

I have tried to run nxt motors from the BrickPi+ with the BrickPi+ library, but they dont work. There are no errors or whatever.

Can someone help me?


#2

First thing to check is your battery voltage.

You can power your Raspberry Pi from USB for programming, but it will not power the motors in this configuration.

Motors also will not operate with battery connected if the voltage is low (below 7 volts I think).

-Kevin


#3

my battery voltage is around 13V on the BrickPi+ Reader Voltage.
It’s powered by 9v battery pack and ac power in the Raspberry PI


#4

I lowered the Volts to under 12V what recommend is. But nothing changed.
Still the programm works, no errors. But motors/Sensor don’t work?!


#5

I don’t have a BrickPi, just trying to offer help from what I’ve read on these forums in the past.

Are you sure you’ve got a BrickPi+ and not the newer BrickPi3?

It would be helpful if you could post the code you are trying to run.

-Kevin


#6

I have the BrickPi+, for sure. Exact version is v2.8.2
I try to run a standard motor test from dexter itself.


#7

Searching the forum, I found this link:

https://www.dexterindustries.com/howto/enable-or-disable-brickpi-communications/

From reading your other posts, I think this might help you.

-Kevin


#8

Thanks for helping Kevin.

But i already disabled ir Receiver. Here is a screenshot:

Is there another solution or problem that i have?


#9

I see what i did Wrong!

I disabled Ir Receiver and disabled BrickPi.
How that i have enabled BrickPi, it worked.

Thanks for helping!