[SOLVED] No SPI response

brickpi

#1

Hello.
I’m trying to run a lego mindstorm motor with the brick.
when i run the examples, I get the error “No SPI response”

How do I fix this?

/


#2

Please start by going here to determine which version of BrickPi hardware you have (original BrickPi, BrickPi+, or BrickPi3).


#3

Hello again,

It’s the Brickpi3


#4

What operating system are you using? On Raspbian For Robots or Raspbian, you can run this command to install/update the BrickPi3 software: sudo curl -kL dexterindustries.com/update_brickpi3 | bash

Try running that and then rebooting the RPi. That should ensure that the drivers are fully up to date. Once you do that, run this command to update the firmware on the BrickPi3: sudo bash /home/pi/Dexter/BrickPi3/Firmware/brickpi3samd_flash_firmware.sh

After the drivers and firmware are updated successfully, try running Read_Info.py (you can use the command sudo python /home/pi/Dexter/BrickPi3/Software/Python/Examples/Read_Info.py). That should indicate whether or not the BrickPi3 is communicating successfully after having updated the drivers and firmware.


#5

I get the same ‘No SPI Response’ error, both when running Read_Info.py and when initializing a brickpi3 object.

I had things running on a previous Pi SD card. I installed the brickpi3 library using the install script yesterday, and

>>> import brickpi3

works fine.

Other info: Raspberry Pi 3 running Raspbian Stretch, BrickPi3 purchased a few months ago, Only lego EV3 motors and sensors connected to the BrickPi3; no other SPI or GPIO devices.


#6

Is the yellow LED on the BrickPi3 near the power jack blinking? If so, how fast (how many times per second)?

Are you powering the RPi through the power jack on the BrickPi3?

Can you confirm that the BrickPi3 is stacked properly on the RPi GPIO pins? It should be stacked on RPi pins 1-26, and it needs to be seated far enough for the pins to make good contact.


#7

Thanks for the quick reply Matt.

I ran the update (sudo curl -kL dexterindustries.com/update_brickpi3 | bash), and that took care of it. Not sure why it needed an update when I did the original installation yesterday and that seemed run without errors.

Voltages & pin connections were fine.


#8

Great, I’m glad it’s working for you now.


#9

This topic was automatically closed after 29 hours. New replies are no longer allowed.