[SOLVED] No title bar for each window opened in Raspbian

r4r

#1

Hi there,

I just bought a Brickpi Start Kit for my boy lately and our problem is there is no window title bar for each app I opened (Terminal, Scratch, web browser). At first I thought it was resolution problem. I use a Samsung Smart TV as monitor. So I tried to change overscan, hdmi format in the config.txt, etc… I can see the black bar of screen was changed but still no window title bar for each app I opened. I can no drag, resize the it. Another interesting thing is the web browser, without title bar, I still can drag it to the center of screen. But can not resize it. It is really annoying.

Please help.

Lin


#2

Hi @hjoe5025,

If I get it right, you can’t see the title of each window you open on your Raspberry Pi.

Would you mind sharing some screenshots with what you see?
Also, what image do you have on the micro SD Card? Is it a Raspbian For Robots, a Wheezy, Jessie or Stretch image? Just so you know, we are currently supporting the Jessie image, which is the most stable image of them all.

Thank you!


#3

Hi there,

I used the SD card coming along with the whole Brickpi starter kit. I believe it is the Raspbian for Robots.
Do i need to update the SD card?
Yes, I will catch a screen shot for you this evening. And thank you very much for the prompt help.

Lin


#4

You were right. I can not see any title bar for every app in my pi.


#5

Hi,

Please see the shot:

!

I am only allowed to upload one image. This is what web browser looks like. The other apps i could not even move them without title bar.

Another problem is I could not see the mouse after pi boot up, until I launch at least one app, usually terminal.

Can you help?

Thank you,

Lin


#6

Hi @hjoe5025,

It looks like you’ve got an old version of Raspbian - this is Wheezy and you need to use Jessie.
I suppose the micro SD Card you’ve got has been flashed some time ago.

Here’s what we want to do:

  1. Go to this tutorial and check the Using a PC section.

  2. Make sure you download the Raspbian For Robots image and not the DexterOS image.

  3. Burn your micro SD Card just as you’re instructed in the tutorial.

  4. Boot-up your freshly burned micro SD Card and update the software with DI Software Update app.

If there’s anything unclear, please let us know. We will be here for your assistance.

Thank you!


#7

Hi Robert,

Yes, updating the Raspbian to Jessie did the magic. Now everything looks normal.
Thank you for the help.

Lin


#8

Hi @hjoe5025,

You’re welcome. I’ll now close the thread.

Thank you!


#9