[Solved] Ports Not Responding in Any BrickPi Samples


#1

I recently bought a new BrickPi, and went through all of the Getting Started steps. I am using an OS image from Dexter Industries. The ONLY thing I did to it was expand the OS partition using raspi-config. Didn’t make any other changes to the image.

Now, I am trying to run some of the simple samples on the device, both Python and Scratch, but nothing is happening. No error messages, no responses from sensors. No motor movements (I have a battery plugged in to BrickPi for the motors).

There doesn’t seem to be an diagnostic tools for BrickPi on the OS. Only tools for some other Dexter devices.

These sensors and motors DO work when attached to a Mindstorms NXT device.

So, it’s looking like I might have gotten a bad BrickPi? Unless someone can come up with something I might have missed.


#2

Two things to try:

First run the led test program to make sure the BrickPi is connected corectly.

If that works:
Make sure that I2C is enabled by runing “raspi-config” from the terminal window. It should be in advance configuration options, but, should be easy enough to locate. Reboot the raspberryPi and then try one of the sample programs - I would suggest either motor test or touch test.

Dave Hartmann


#3

The LED test does work. I see two blue LEDs blinking when that runs.

I made sure I2C was enabled. It also asked if I should enable it in Kernel Mode, and I said “Yes”, to that, too.

But, still no responses from the ports.

The LEGO-Motor_Test.py returns “Running forward” and “Running backward” messages. But, no motor movement.

The LEGO_Touch_Sensor_Test.py doesn’t return anything. The source code has port 4 set for this test, though the comment line says “Port 1”. But, I tried all 4 sensor ports with it, anyway.


#4

Hey Mitch, just want to check: what was the date-name on the OS you installed? Or did you buy the SD card from our store?


#5

It’s an OS image I downloaded from your site. V 6.6, updated on 2015.11.04.


#6

Ah, ok, I think I have an idea. For the very latest version, you might have the Infrared Sensor for Grove enabled.

The BrickPi, unlike all our other products, uses the serial lines not the I2C lines. With the new image, the serial lines are disabled and enabled to allow an Infrared remote to be used with the GrovePi (another product). You have to switch back and forth between the GrovePi IR sensor and the BrickPi (you can’t use both at the same time).

Short answer: click on the IR Receiver icon in the lower left hand corner of the desktop. And then disable the IR Receiver. After you do this, you should be getting communications from the BrickPi.


#7

Just tapped out a quick “How To” on this issue.

http://www.dexterindustries.com/howto/enable-or-disable-brickpi-communications/


#8

Same problem here, but I’m not using the Dexter OS image, I’ve downloaded the BrickPi drivers/utilities. Where can I find this utility to try disabling the receiver? (My LEDs work fine). Thanks,
David


#9

That worked! :slight_smile:

Thanks for your help! And, be sure to add those steps to any Getting Started instructions you put out!


#10

Hey Mitch, great to hear it! We will indeed add this to the startup notes. Thank you for letting us know!


#11

@Davesin, the issue might be with your serial setup. If you’re not using the Dexter Industries image, is is possible to upgrade your software to use it?

If you need to use your own software, you need to make sure that your serial GPIO’s are enabled. Does that help?


#12

John,

>If you’re not using the Dexter Industries image, is is possible to upgrade your software to use it?

Would rather not since the Pi is not exclusively used for Brick stuff. So how do I make sure the serial GPIO’s are enabled? And you don’t think that disabling IR would help since the symptoms are the same, LEDs are functioning? (ie. is it IR not relevant when not using the Dester image?). Thanks,

David


#13

John,

OK, problem resolved via a different direction, I loaded the Dexter image on a separate card and everything works fine.

David


#14

Ok, great to hear. I’m going to close this thread since it’s solved! Thanks everyone!