[SOLVED] Raspberry Pi boot fails only with Grove plugged in

grovepi

#1

Hi, I’m on Raspberry Jessie.
My Pi boots normally without the Grove shield plugged in.
However, when plugged in, the boot only reaches the screen with 4 raspberries.

I’ve successfully run the sudo curl -kL dexterindustries.com/update_grovepi | bash command.

Is there only a specific kernel version that is supported or something? How do I verify that the software is setup correctly?

Thanks!


#2

Hi @workspace0017,

I have 2 questions for you:

  • Is there a black foam attached to the GrovePi's header pins?

  • When you ran sudo curl ... command, did you have the GrovePi attached to your Raspberry Pi? Did this issue appear only after running the former command?

I don’t think there’s a correlation between the kernel version and the fact that your Pi doesn’t boot - just yet.

Also, the command necessary to install the GrovePi should look like:

curl -kL dexterindustries.com/update_grovepi | sudo bash

or

sudo sh -c "curl -kL dexterindustries.com/update_grovepi | bash"

The idea is to run the script with root privileges.

Thank you!


#3

Hi Robert,
Thanks.
No black foam attached.
I ran the command (curl -kL dexterindustries.com/update_grovepi | sudo bash) without the Grove attached.
I don’t know if there is an issue with GrovePi attached and command unrun as I didn’t try that.


#4

Hi @workspace0017,

I’m starting to have doubts about the kernel.
Does rolling back the kernel to 4.4.50-v7+ work for you?
Here’s the command you have to run:

sudo rpi-update 52241088c1da59a359110d39c1875cda56496764

Thank you!


#5

Hi Robert,
thanks for the prompt support.
This kernel version works.


#6

Before closing this thread, this other thread is related to the one in discussion: