[SOLVED] Raspbian for Robots desktop only permits one window open at a time


#1

My Raspbian for Robots Dexter desktop only allows one window open at a time which cannot be moved nor resized. For instance, if I have the Terminal window open, I cannot even see the menu bar to choose another app. The menu bar also clips off the top of the upper icons on the desktop. I’ve tried enabling/disabling underscan with no change. The regular Raspbian Jessie desktop on my other raspberry pi’s doesn’t do this. See the attached window snip showing a terminal window that shows the OS version. The same is true if I use Remote Desktop instead of the Dexter VNC. Right clicking on the open window does nothing, offering no options. This can’t be normal. Suggestions?
Thanks!
RoboDoc


Windows stack top left only
#2

Hello @jhphelan

You are right, this is indeed not normal. Is this a fresh installation? Or did you run an update on it?

#puzzled
Cleo


#3

It has been updated. I believe it has acted this way from the start.
Using the SD card that came w/ the kit. I have another that I burned
from a downloaded image. I’ll check how that one behaves.

I seem to be an expert in destructive testing of software. If there’s a
strange bug, I’ll find it!

RoboDoc


#4

Hello @jhphelan

I know the feeling. I find all sorts of weird bugs too, but not in my own code base unfortunately.

May I ask how you did the update? Did you use the DI Update script, or did you update via apt-get ?

Cleo


#5

Cleo,

I did the DI Update script. I /may/ also have done apt-get update in
attempt to fix something that wasn’t working. Is it a bad idea to
apt-get update?

I just rechecked the system. Now, the desktop won’t even open ANY app,
not even menu. I swapped to my other SD card w/ downloaded R4R and it’s
doing the same thing! Can’t open anything. In addition, using the
terminal DI window app instead of VNC, I can navigate and list, but when
I tried raspi-config the -_/? characters wouldn’t display at all. See
below, don’t know why it happened or fixed itself!

If I re-boot from the downloaded R4R w/ HDMI, mouse & keyboard, all is
normal.

The DI R4R displays HDMI but doesn’t recognize keyboard & mouse (MOST
annoying, please fix this) so I have to go headless. Booting back to
the DI SD card, I can now open apps, but still can’t move them or see
the menu bar.

Is there a downloadable image that is EXACTLY like the DI SD card from
the kit?

Meanwhile I’ll re-download the DI R4R image & burn another SD card and
try again.

Thanks for your attention on this,

RoboDoc


#6

Cleo,

Should I download

2017.10.05-BETA_Dexter_Industries_jessie.zip
or
2017.09.28_Dexter_Industries_jessie.zip

I’m leaning /away/ from BETA.
I suppose I can try both…

RoboDoc


#7

Cleo,

Ok, I burned a new SD card from both the Beta and Jessie options.

They seem to work ok.

I /think/ the problem came from configuring the Pi after network setup.

sudo raspi-config is VERY CONFUSING when it comes to setting up for the USA.

Just exactly what the heck are all those cryptic options?? The GUI
option is MUCH easier so I tried that way. I ignored the warning and
proceeded to setup for Central USA. Maybe that screwed it up. When I
tried again with the fresh SD card. the Internationalization/Keyboard
button wouldn’t click even though it had in my previous attempt. That
was my clue. Started over and went the sudo raspi-config route and
/hope/ I got the right settings. Seems to be behaving. At least all
the punctuation characters work.

BTW, the keyboard & mouse are working plugged into to Pi now.

I haven’t tried comparing the Jessie and Beta versions as that’s
probably too deep for me to decipher. I’ll stick with Jessie which I’m
expecting to be more stable unless you tell me otherwise.

Will keep you posted of any further problems.

RoboDoc


#8

Hey @jhphelan,

Good sleuthing there! It seems the Raspbian OS is playing tricks on us. raspi-config has never been clear to use, especially for internationalisation. May I ask which characters were bothering you? It seems to be fine for most people without having to change anything.

So just to be 100% sure, you’re now able to work/play/develop/teach properly, right?

Cleo


#9

Cleo,

For a while, none of -_=+|/? would work. When I try to enter
raspi-config, the - wouldn’t display! Since Pi are from England, they
default to British settings. When using the GUI to change to US English
it wanted to default to US Spanish (?!) and I had to scroll up to find
US English! The British keyboard would change some punctuation
characters. I guess/hope the default “all locales” that defaults to
en_US.UTF-8 would work.

As far as “you’re now able to work/play/develop/teach properly, right?”,
I’ll re-start the programming experiments again tomorrow. My first
attempt at the “Intelligent Object Avoidance” was more like “Stupid
Object Avoidance” as it would mildlessly plow into walls and furniture
even though I had confirmed that the distance sensor worked properly.
Let’s see what tomorrow’s experiments reveal!

RoboDoc


#10