SSH password for Dexter Industries Raspberry Pi SD Card


#1

Hello,

I am working on a robotics project involving a Raspberry Pi and BrickPi attachment. I would like to do an ssh into the pi from my MacBook Air (OS X El Capitan 10.11.5).

Normally, when I plug in the SD card (which has a Dexter Industries image to be compatible with the BrickPi) the pi runs through its start-up sequence without asking for a username or password, then it displays the desktop. When I attempted to ssh, the mac terminal asked me for a username (probably a password too but I don’t know since I am stuck here).

Even though I do not input any password when the pi starts up, the terminal still asks me for one. I have tried simply hitting “enter” to show that there is no password or username that I know of, but it still asks me for the username.

Is there a way I can get the username and password for the pi? I would be grateful for any help.

Thank you very much


#2

Everything’s normal. Your username is pi and super crack proof default pasword is: robots1234 Secure right! I’d recommend you change it though. Here’s some instructions for that if you want.


#3

The mac terminal prompts me for a password only, so I input robots1234, but it still asked me for my password another 2 times (three times total). After the third time, I get the following message:

Permission denied (publickey,keyboard-interactive).

I have tried using raspberry, I have also tried inputting the username first with the two possible passwords, but it still gives me the three prompts and the same message. So from start to finish (after inputting the passwords), the terminal looks like this:

YKT-STU-C02PXC7XGFWM:~ student$ ssh 127.0.0.1 -l pi
Password:
Password:
Password:
Permission denied (publickey,keyboard-interactive).

I am on wifi (since my MacBook air has no ethernet port) and my raspberry pi is connected to the internet through an ethernet cable. I have also enabled ssh on the raspberry pi before starting.


#4

The email method to reply didn’t work; so if a duplicate of this reply is found I’m not spamming if that happens.

Anyways you need to ssh like this: ssh username@ipadress
Also your IP address is incorrect for ssh. Run hostname - I in the terminal. Then use the IP address that is not the one you are currently using.

However you can simplify this whole thing by just typing ssh pi@dex.local. Simple right? No IP address needed because Raspbian For Robots is automatically configured so that you can ssh into it with the hostname.

The methods above should work, if not let me know.


#5

You must type pi@127.0.0.1. In order for it to work. Also you appear to be using the wrong IP address. On your pi type hostname -I in the terminal. Since your using raspbian for robots, you can simple just type ssh pi@dex.local Which I recommend you do that.

That should work, in theory.

Everything works in theory! :slight_smile:


#6

THANK YOU SO MUCH. Today was the only day I had enough time to do what you suggested, and it works. I found that the password is indeed “raspberry” and I was able to run some code on the pi.

Thank you all so very much, I have been trying so long to do this.

Thank you again!


#7

On second thought, I just encountered another problem.

After I ssh into the pi, I was able to run programs on my mac. I then closed the mac terminal, closed the raspberry pi terminal, and unplugged the raspberry pi. I turned the raspberry pi on again (same SD card), I went into terminal and did hostname -I but nothing appeared, I did it several times but still nothing (none of the cables were removed, just the power one). So I did sudo raspi-config and I enabled ssh again. After doing so, I ran hostname -I again and it gave me another IP address. I used that IP address, and I get:

Last login: Wed Mar 22 11:22:05 on ttys000
YKT-STU-C02PXC7XGFWM:~ student$ ssh pi@169.254.7.29
ssh: connect to host 169.254.7.29 port 22: Operation timed out

I then tried ssh pi@dex.local, but this message appears:

YKT-STU-C02PXC7XGFWM:~ student$ ssh pi@dex.local
ssh: Could not resolve hostname dex.local: nodename nor servname provided, or not known

I tried putting in another SD card, but it says the IP address is the same and I still have the same problem of it timing out, despite the fact that the first time I was able to ssh and run code on the Rpi.

I am truly baffled, and still, need help, please.


#8

Hi @radut,

When you tried with an another SD card, which image did the SD card have. If you are using a Dexter Industries’ Raspbian for Robots image, can you tell date of the image. Also to login if you have Dexter industries’ image then you can try to ssh with pi@dex.local or type dex.local on the address bar of your browser to access your Pi.

-Shoban


#9

I used another card with a dexter industries image. The version stated is “V2.0 This version of Rasbian was modified by Dexter Industries on the Wheezy Raspbian 2013.12.20 Build.”

Additionally, I have found something interesting, sometimes, the command " hostname -I " doesn’t give me any IP Address, even though the ethernet is connected and the lights are flashing on both the modem and the Pi. However, sometimes it does (169.254.7.29). Using “arp -a” on the terminal in my mac, I scanned the devices on the local network and I got this line for the Raspberry pi

YKT-STU-C02PXC7XGFWM:~ student$ arp -a
? (169.254.7.29) at (incomplete) on en0 [ethernet]

So does this mean that the PI doesn’t actually have internet connectivity? The reason I say this, is because I am using my high school’s network, which places various restrictions on websites and things you can do on the internet, could this be one of them?

I am also confused on the dex.local, I type dex.local in the mac google chrome browser, but I get an error screen saying

This site can’t be reached

dex.local’s server DNS address could not be found.
Search Google for dex local
ERR_NAME_NOT_RESOLVED


#10

Are you sure your using Raspbian For Robots? Does your desktop have the Dexter Ind logo? You said that the raspberry password worked. That means your using raspbian. Dex.local will only work on raspbian for robots.

If you would like to find out if your pi is online try typing this into its terminal? ping google.com if it does your online, if not you may be online but the network may just block pinging websites. You could also try downloading a file with curl or wget.