Suddenly problems with BrickPi & Firmware


#1

Hi, :slight_smile:

suddenly I got a problem with the firmware of the BrickPi.
I ran the LEGO-Motor-Test.py with the command sudo python LEGO-Motot-Test.py in the Sensor_Examples Folder but nothing happened. The cpu load was higher (25%) for the next 30 seconds. Then the Motors moved.

When I run the EV3-Ultrsonic-Sensor-Test.py (for my EV3 Ultrasonic Sensor) nothing happend too. After long wait neither.

The LED-Test works fine.

And when I run EV3-Firmware-Check.py following is the output:
set up sensor returns: -1 and i have to wait very long.

The strange thing is, that all worked fine before… :unamused:

I hope someone can help! Thank You in advance! :grinning:


#2

It sounds like failed communication between the Raspberry Pi and BrickPi. What changed since it was working? Did you update the firmware? Did you update the software?


#3

Do you have the Brickpi plugged into its batteries? That could be the problem. Maybe it wiggled and got loose and the connection is bad.


#4

Thanks @Matt @graykevinb for answering!

I updated my Raspbian-System of my Raspberry Pi. First I thought that was the point.

But I have solved the problem. Like @graykevinb described, it could be that the the cable wasn’t inserted right.
Anyway, I turned off all devices and disconnected the batteries and the other cables and tried it again. Then it worked! :slight_smile::grinning:

Thanks anyway for your help! Have a good weekend! :relaxed:


#5

Awesome! :grinning: Glad its working. You too! Have fun with your brickpi! If you make anything I’d love to see your robot.