Think I have killed my PI and Brick PI


#1

Hi,
So last night I finally had everything assembled, new model B PI, BrickPI, simple robot and started testing with the latest dexter image.

I was having trouble with the scratch examples, see post in scratch topic. This meant I kept picking the robot up to get the motors off of the ground, just to make sure the motor was not being prevented from spinning.

On my last attempt the battery pack slipped off of the motor and the PI switched off. I was powering everything through 8 AA batteries connected to the BrickPI.

Disconnecting and reconnecting the battery did not do anything. So I stripped everything down, removed the brickPI and used a micro usb PSU. Still no red light.

I searched the PI forums and there was a comment about waiting 24 hours for the poly fuse? to reset.

Now to my question, if I just apply power to the BrickPI is there anything I can check to see if it is working?
Although as I write this it has just occurred to me that I could measure the volts on the raspberry PI connector.
Anything else I could look at?

If I have killed the brickpi what is the cost of a repair? Would I have to ship it back to the USA or via the distributor in France?

Cheers

Steve


#2

Steve,

Sounds confusing. In short, it sounds like the power was pulled on the BrickPi / Raspberry Pi suddenly. This in theory shouldn’t have caused a problem. A few questions, a few recommendations:

  1. Just to repeat: when you remove the BrickPi from the Pi, and power up the Pi alone, without any USB peripherals such as a mouse, wifi device, etc, through the micro-usb adapter, with a USB power source, do any of the lights turn on? Is there any activity at all? In particular, is the PWR LED on the Pi glowing red?

  2. Do you have another SD card with a Raspberry Pi image on it? If you don’t is it possible to re-burn your current SD Card?

  3. Just to clarify about 1. The USB power source you’re using, have you used it to power the Pi before?

There’s not a way to test the BrickPi without the Raspberry Pi (there is, but it would require some breadboarding and wiring and probably be overcomplicated). Let’s focus on seeing if we can get the Pi running alone first.


#3

Hi,

When I powered up the PI that night with a supply I had used before no LEDs came on, no sign of life.

I read somewhere about the PI having a polyfuse fitted and leave it 25 hours to reset which I did. This morning it all burst back into life . I refitted the brick pi and that worked as well. So panic over !

My only issue now is with motor D. I have modified the scratch motor test program to use output A and D.
When I press the up arrow key A rotates, D does not until I change direction!

I will dig deeper with that issue and in future make sure my battery pack is firmly attached to the robot!

Cheers

Steve


#4

Hey Steve,
That’s fantastic that it all came back to life, a sigh of relief on our end. Also, thanks for sharing that about the polyfuse. Another nice thing to know about the Pi.

So regarding motor D: are you comfortable enough with Python to try the motor test program? This could rule out any hardware issues.

Also, we would strongly recommend updating the image if you’re not already using the 06.2014 image.


#5

Hi,

Can’t get python to work at all.
I have modified the car example to remove all reference to the distance sensor as I have not got one.
So the program enables motors A and D and then responds to key board presses. No motor moves.
I am using the 2014.06.05 image.

I assume with python I just enter sudo python prog.py, do not need to run anything else?

Cheers
Steve


#6

Let’s first try to get Python to work.

If you’re on your BrickPi, power enabled, and motors plugged into Port A and Port B. Can you go to the motor example in DesktopBrickPi_PythonSensor_ExamplesLEGO-Motor_Test.py

If you change directories to DesktopBrickPi_PythonSensor_Examples and type
sudo python LEGO-Motor_Test.py

What is the result? Does the motor run, or do you get an errror?

Also, we’re tracking your post here: http://www.dexterindustries.com/forum/?topic=error-in-scratch-axe-example but since this is redundant, I’ll try to answer here first.


#7

Right, sorted.
The lego examples worked, so back to my modified wifi-car.py example.

I was correct in having to remove the sensor reference for it to work, but as ever I deleted too much!

I deleted a class which was calling brickipdatevalues, ( hope name is correct). I had noticed in the lego examples that this function was constantly being called. By adding it into my program everything worked.

I have just modified my program to use motor A and D, rebooted the PI and it all worked.

Apologies for waiting your time, I will now add Bluetooth and modify the program to control the robot via my wii mote . Then I want to look at using a camera to track a light.

Cheers Steve Gale


#8

We’re so glad to hear it worked! Can’t wait to see the results!!

No waste at all, I’m just so glad we got this working.