Trouble connecting to PC


#1

I just purchased the GoPiGo Starter Kit and followed the instructions up until connecting to the PC(Windows 7) (http://www.dexterindustries.com/GoPiGo/getting-started-with-your-gopigo-raspberry-pi-robot-kit-2/4-connect-to-the-gopigo/)

  • I dowloaded Bonjour and did steps 1-5 on the linked page.
  • When I try to connect to dex.local through putty, I get the “host not found” message. From reading other posts concerning connection errors, my hardware seems to be working correctly(all lights blinking), so I guess it’s a network problem.
  • I wanted to try assigning a static IP following this tutorial: https://www.youtube.com/watch?v=P4yg8RYtTJs&index=5&list=PLGXEJ4Ye1qCMWziVrynnrIPpgfOr-2aj9 But when I insert the SD card into my computer, I get a message that it has no filesystem and the card needs to be formatted before I can use it. It’s the SD card that came with my Starter Kit, "Raspbian for Robots 2015.11.09"
    Is this normal or is my SD card broken? If I format it, which filesystem should I use?

Thanks for any help!


#2

I am just another user not an expert but We have had good luck with the newest update we reiamged all our “old” Dexter cards. Good Luck!


#3

I tried to re-image the card according to the instructions on the dexter page, but I can’t even write the image to the card… Win32 Imager throws the following error (see attachment). I seem to have gotten a bad SD card?

EDIT:
I figured out that for some reason the SD card can not be read by my laptop once it was inserted into the RaspberryPi. I followed these steps to format my SD card, after that the whole 8GB were recognized again and I could re-image the card. I tried connecting the GoPiGo again with the new image, but with the same result as before(host not found), so I wanted to try assigning the static IP… just to find that my SD card had turned unreadable AGAIN. Does this mean that I have to wipe, re-format, re-image the whole SD card EVERY TIME I put it into the RaspberryPi for it to be readable for the laptop? :frowning: Please tell me there is a better way to do this… (I am completely new to RaspberryPi and GoPiGo)


#4

Hi ZZ1,

No, you should NOT need to re-image your SD Card each time you turn the Pi on and off. HOWEVER, you will indeed corrupt the image if you pop the SD card out of the Pi wile it’s still powered. You MUST power off the Pi (even just remove the power) and THEN pop the SD Card out.

If you did power down the Pi and GoPiGo and then you’re still getting corrupted, we can send you another SD Card to make sure that the one we sent you originally isn’t damaged. If you did pop it out while the power was on, you should try to re-image the card and be careful not to remove it while powered in the future. Please let us know what you try / what happened.

Thanks Jeff for stepping in here.


#5

Hi John,
thanks for your reply, I followed the instructions very carefully and never popped the SD out while the power was on. (What I’m doing is, turn the power switch off, take the wall adapter out, remove the Ethernet cable(because it’s very short), and then take the SD out.

Btw, I tried assigning a static IP yesterday, and while now I can ping that IP, I only get the reply that the connection could not be established. If I try connecting via putty, I also just get a timeout after entering user+password. (Now with the new image 2016.01.05_Dexter_Industries_wheezy)


#6

Hey ZZ1, that’s the correct way to turn off the Pi! Just wanted to be sure, sounds like you’re doing it right.

Sorry, so you can ping the IP address and you get a good reply. Is that right? If true, that’s a step forward!

You wrote “I only get the reply that the connection could not be established. If I try connecting via putty, I also just get a timeout after entering user+password. (Now with the new image 2016.01.05_Dexter_Industries_wheezy)”

If you type the IP address into your browser (like Firefox or Chrome) http:169.x.x.x , does it take you to the Raspbian for Robots homepage and show you VNC or terminal?


#7

I guess then my SD card might be corrupted - can you send me a new one?

Sorry I was not clear on that, when I ping the IP address, I DO get more than just the typical “host not found”, the ping tries to send out data and I get the lines describing the ping, but each line reads “host could not be reached”. (I attached a screenshot, sorry my OS is not in English but maybe you get a better impression of what’s happening.)

When I try to enter the IP into my browser, I just get a timeout.

Thanks for sticking around, John!


#8

Just to confirm: when you ping dex.local, you get the same response? Or if you try to connect through the browser, you get the same response.

Sure, if the SD Card arrived damaged, we’ll definitely replace it. Please contact us here: http://dexterindustries.com/contact and reference this forum thread (paste the link into your request for a replacement).

Thanks!


#9

dex.local never worked for me, neither ping-ing, putty or opening it in the browser, using the image on the card as it came, or after re-imaging. :frowning: I’m not sure if I should be able to see dex.local in Bonjour, but that can also not find it.

Thanks for the link, I will contact you there!


#10

Did your ethernet lights ever come on? Do they come on when you power the Pi up and connect to your computer?


#11

Yes, they are on, one green and one orange.


#12

If the ethernet lights are on (these are the LEDs on either side of the raspberry pi) the image is definitely not corrupted. If we take two steps back then . . .

Do you have the wifi dongle plugged in? If so, please remove it.
Can you turn off the wifi on your computer?

If you take these two steps, can you ping your Pi?

If that doesn’t work, can you tell me the two IP numbers you used: the one your computer has, and the one you assigned to your Raspberry Pi?


#13

Ethernet lights are on.
I didn’t use the wifi dongle in the tests described before.
I turned of my computer’s wifi and tried to ping again, with the same result as described above.

Laptop’s IP: 192.168.178.20
Assigned IP: 192.168.178.21


#14

Some folks have had success assigning an IP address that’s two digits away from their own IP address. In your case 192.168.178.22

Can you try to assign the new address?


#15

Ok I will try that, but as I have to reformat the card to access the cmdline.txt I don’t have time to do it right now, but I’ll come back with the results. :slight_smile:


#16

Got it. No rush from my end, but I’m curious why you have to format the SD card to access the cmdline.txt ; could this be a problem with the PC you’re using? Is it possible to put it into another machine?

One other option might be, if you have a keyboard, boot up the PI with an HDMI monitor and edit the file in the command line (it’s at /boot/cmdline.txt)

But now I’m really intruigued, why does the SD Card format every time you put it into the PC?


#17

It’s the problem I described here: http://www.dexterindustries.com/topic/trouble-connecting-to-pc/#post-78340
I don’t know if it’s my machine, as it reads other SDs just fine… I don’t have another computer to try with unfortunately.

I think I will try the monitor+keyboard next.


#18

Hi again,
I tried to assign the new address 192.168.178.22 directly on the Pi using monitor+keyboard. While booting I noticed a message that said something along the lines of “the device was not unmounted correctly”, could that be a hint concerning the formatting problem?
Otherwise everything looks fine when booting the Pi, and I was able to change the IP.

Sadly, still no luck establishing a connection, getting “host could not be reached” again as shown above. (Ethernet lights blinking, no wifi dongle, wifi of laptop turned off)


#19

Hey ZZ1, that number looks like a wifi address, not an ethernet address. That’s fine, it might work. Since you have the Pi setup with a monitor and keyboard, can you try to log your Pi into your wifi network. If that’s successful, can you ping google.com from your Pi? And if you can do that, can you put your laptop on the same wifi network, and ping dex.local?


#20

Hi John,
I tried setting up wifi but to be honest I have no clue how to configure this under Linux… I found a lot of different configuration examples online, I treid a few but nothing worked.
I edited /etc/network/interfaces like so:

auto lo
iface lo inet loopback
iface eth0 inet dhcp
auto wlan0
allow-hotplug wlan0
iface wlan0 inet dhcp
wpa-ap-scan 1
wpa-scan-ssid 1
wpa-ssid "my ssid"
wpa-psk “my pwd”

with my data in the last two lines.
If I do sudo service networking restart, I get the output that you can see attached.

One question, are all these configurations needed to run the GPG, or is there an easier way? The only thing I want to do for now is writing Python code and executing it on the GPG. I might get deeper into the Raspberry etc. later, but I’m a begginer with all of these so I’d just like something basic that works.


EDIT:

I also noticed that when I try to use the graphical interface for wifi configuration, it is just empty: no adapter to choose, no networks, and when I run Scan nothing is found.
On the other hand I see my network when I run sudo iwlist wlan0 scan.

I also tried following the steps on this page: http://omarriott.com/aux/raspberry-pi-wifi/
Everything appears to have worked like in the example, I get an output like

pi@raspberrypi ~ $ sudo ifup wlan0
ioctl[SIOCSIWAP]: Operation not permitted
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument
Internet Systems Consortium DHCP Client 4.2.2
Copyright 2004-2011 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/wlan0/00:e0:4c:10:60:fc
Sending on   LPF/wlan0/00:e0:4c:10:60:fc
Sending on   Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 5
DHCPREQUEST on wlan0 to 255.255.255.255 port 67
DHCPOFFER from 10.0.1.1
DHCPACK from 10.0.1.1
bound to 10.0.1.59 -- renewal in 33153 seconds.

and I see that the wlan0 has an IP address when I do ip addr.

But I still can’t ping anything, not even my laptop.