Troubleshooting Brickpi not connected[SOLVED]


#1

just started playing with my brickpi. It boots up with a monitor connected and I have been able to run it from my mac via VNC, so the Pi part of it works. But I cannot seem to get it to recognise sensors or run motors. I ran the hardware test only to be told that there is no brickpi connected! Any suggestions?

The Pi is a Raspberry Pi 3B and the BrickPi board is v2.8.2. The whole thing is running off a disc image downloaded from Dexter one week ago.


#2

@christian2,
Can you post a few pictures of the BrickPi. Also, how are you powering the whole setup. Can you run the example given here and post the output on the forums .


#3

I had similar issues with mine. It’s probably the pins are connected
totally. Try pushing it all the way, even if you have to take the case off. Just don’t apply force, it should go on easily.
for robots it should be already installed. Like @karan said the pictures
would help. It’s probably just a loose connection.


#4

Karan, sorry for being slow to respond. please find pictures of my brickpi and screen grabs from VNC. It appears that I can only place one image in a post, so I have uploaded the images to my dropbox.

This is the link: https://www.dropbox.com/sh/7el50a8hlq7fp29/AABu-43RWx4yFuqOMexdcyhya?dl=0


#5

Hi @christian2

We aren’t able to view the images in the link that you have sent. Can you post the images here one by one.
Sorry for the delay in reply.

-Shoban


#6

here is a side view:


#7

here is the other side


#8

here is an end view


#9

here is the whole assembly


#10

here is the output of the Dexter test utility


#11

here is the firmware check output


#12

Hi @christian2,

Thanks a lot for sharing the images and also for testing. It looks like there is a slight confusion with BrickPi3. So the troubleshoot that you are trying is for BrickPi3. The BrickPi that you have is BrickPi+. The codes and sensor examples for BrickPi+ are available at /home/pi/BrickPi+/Software/BrickPi_Python/Sensor_Examples.

If the examples here aren’t working then can you run
sudo python /home/pi/BrickPi+/Software/BrickPi_Python/Sensor_Examples/BrickPi_Hardware_Test.py and send us a screenshot of the output. You can also find this script here.

-Shoban


#13

Shoban,

thank you - I can get the touch sensor example working. The hardware test displays an error message about indentation, but as the touch sensor is working I am just going to ignore hardware test I think.
Thank you again


#14

Hi @christian2,

Good to hear that it works for you.

-Shoban