Using "raspbian for robots" via SSH and WLAN

#1

Hi,
i´m going to connect BrickPi 3 to a Raspberry Pi 3 (B+) for a student project and use the operating system “Raspbian for robots”. The Raspberry Pi should communicate with a PC via SSH and automatically log in to the WLAN-Network.
For this way I got some informations to paste two files into the boot partition of the SD-card. One empty file to activate ssh and one file “wpa_supplicant.conf” which includes the WLAN-configuration:

country=DE
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
network={
       ssid="wlan-name"
       psk="password"
       key_mgmt=WPA-PSK
}

Unfortunately the Raspberry Pi doesn´t log in to the network and after the first boot the “wpa_supplicant.conf”-file still exists. All LEDs lights up correctly (The ACT is blinking). Is there a different approach for the “Raspbian for robots”-system to realize this requirement?

Best regards and thanks for any help!

Stephan

#2

Before anything else, I assume you put in the right SSID and password, right?

If I were you, I’d take out that key_mgmt field out and see what happens. Just out of curiosity.

#3

This is the same method I use for bringing up my GoPiGo3 with Raspbian for Robots OS, albeit I used “country=US”.

There was a time that I also had to disable ipv6 but not recently:
=== disable ipv6

Browse the disk (boot)
Rt Click on System Volume Information->Open Terminal Here
(or cd boot)

cp /boot/cmdline.txt /boot/cmdline.txt.bak
nano /boot/cmdline.txt
add to end of line/file:
ipv6.disable=1
save, exit editor

eject disk