Using sesors and motors at the same time

When ever I try to use the Utrasonic Sensor at the same time as the Motors it says

Connected to Scratch successfully
Setting up Sensors Done
Setting up Sensors Done
Severce Started
Traceback (most recent call last):
  File ""/ line 128, in <module>
  File "/usr/lib/python2.7/", line 489, in start
    raise RuntimeError("threads can only be started once")
RuntimeError: threads can only be started once

I don’t know what is wrong

We are having an identical issue. Have tried everything we can think of. Please HELP!

1 Like

I didn’t find a fix to this so I learned python and coded python. You can learn it easily at . Free and Easy to use for any age.

1 Like

Thanks for the response. May have to go that way, which is a bit frustrating as the project was something my 6 year old son and I were doing together. Still, as I say, thanks for the update.

1 Like

Hey folks,

We’ve been working on full re-work of the Scratch interface for the BrickP. Information on it is in the latest issue of MagPi:

I think this problem should be solved. The writeup is really great and walks you through setup and use.

1 Like

@kimandjack3 Welcome to the Dexter Industries / Modular Robotics User Forum.

Your post on this thread appears to offer help, but the post is from seven years ago.

Are you a new user of one of the Dexter Industries or Modular Robotics products?

1 Like