VNC Connection Setup


#1

I’m also having trouble connecting to my brand new BrickPi (starter bundle). No luck with WiFi or LAN connection. I’m certainly no expert in programming or electronics but I’m a technical guy (two engineering degrees) but this BrickPi is really difficult to get rolling. Since there are no instructions (web instructions so not stand alone) things are a bit confusing.
Upgrading the image seems like a good thing but I’m not really sure how to accomplish that task. I’m hesitant to wipe out my brand new SD card that came preloaded with all the stuff needed to get the BrickPi at least communicating with a host PC.
I can supply the particulars of my troubles but they really are not different than the ones already listed. Tried Windows7 and Windows 8; WiFi and LAN. Powering with a 9V, then with the (8)AA battery pack. Communication with VNC and putty. Windows shows that the BrickPi is an Unidentified LAN connection. Various IPs have been tried. Any suggestions???


#2

Hey WolfePi, if you’re not up for upgrading the image, no problem: we can try to coach through the challenges with the old image.

First, you’re plugging your Raspberry Pi into your computer over ethernet, is that correct? Directly into your Win7 machine, correct? Were you able to make the changes outlined here, http://www.dexterindustries.com/BrickPi/getting-started/using-the-pi/, to your laptop/desktop computer? It sounds like there may have been a step missed with this as windows is showing it to be an unidentified LAN connection.

When you plug in your RPi to your computer over ethernet, do all of the LED’s next to the LAN light up?

When you modified cmdline.txt, can you past the line you modified it to?


#3

My image is dated 7-2013. The primary computer to interface with the RPi is a Win8 machine. We have another machine running Win7 so that is an option. I’ve tried each. We are trying to plug the RPI directly into the Windows machine. I was able to make the changes in the outline. All of the LEDs next to the LAN do light up using the (8)AA battery pack (had low battery issue at first using a 9V). I’ve tried to ping the RPi IP after the ‘unidentified’ LAN connection is made with no response. I’ve also not used VNC or putty before so that is also new but I imagine a good ping response is a prerequisite to opening a connection with either of those programs.
Ultimately, I would like to get the RPi connected by WiFi (tried to do that as well) but I figure that connecting by cable is a good first step.
Here’s the line from the cmdline file that is saved to the SD card modified with the IP that we are trying to assign to the RPi:

dwc_otg.lpm_enable=0 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait
ip=169.254.198.106


#4

Ok, great. Indeed, getting a ping out of the new device is important and if you can’t do that, you probably don’t have a connection.

So, if all of the changes to the Win7 are made, my next question:

It looks like “ip=169.254.198.106” is on a new line. This should all be on the same line. It appears from your paste that it’s not all on one line. If it’s on two, it will fail.


#5

I agree that it does look like the ip address is on the next line, but that is just how it looks. I double checked, the whole thing is on a single line. I just tried to connect again with the Win7 machine; same results no connection. I do run Norton so maybe there is something with that program. I turned off some settings in Norton, but nothing seemed to help.


#6

Maybe I jumped the gun here. Is the image even booting? In other words are you able to get the Pi going with an external HDMI monitor, or are there any other signs of life?


#7

I connected a USB keyboard & mouse along with an HDMI cable to my TV. The BrickPi image boots and I can launch various programs. I still have the same trouble connecting by WiFi or LAN. None of the posted instructions produce positive results; modification of the cmdline.txt or the modification of the interfaces file by typing in the terminal: sudo nano /etc/network/interfaces and modifying the information to match my WiFi network. All of the network lights are on on the RPi. I have the (8)AA battery pack installed along with the micro USB cable connection to my computer.
The LAN connection still shows up as Unidentified network: Public network in the active networks listing in Win7.
Is there a way to tell if the RPi network hardware is working?
I’ll need to get a USB hub if I want to connect the WiFi dongle and the keyboard & mouse all at the same time to try to setup the network with the WiFi Config program on the BrickPi; can’t seem to get the settings to be accepted otherwise??


#8

With the addition of a USB hub iwconfig now shows that the WiFI dongle is recognized; there is no network connection. No information is shown in the WiFI config program that can be launched from the desktop. I’m thinking that the wpa_supplicant.conf file does not have the right information, but I’m not sure.


#9

WolfePi,

Great, so the RPi and the image are working, we’re just not able to connect it to a network (correct me if I’m wrong). You ran ifconfig, and you see an adapter at wlan0.

On that version of the image, the Wifi config program (the graphical version on the desktop) is not functioning.

Under wlan0, do you see an RX and TX count of anything more than 0?

If you seen more than 0 on the RX/TX line of ifconfig, are you able to start midori, the web browser, and connect to the internet from your Raspberry Pi?


#10

Under wlan0 Rx and Tx count are both zero. I’m not sure if the RPi is configured correctly. I still can not connect via LAN either but I found more postings on the WiFi connection so I focus my efforts there.


#11

So if wlan0 is showing Rx and Tx as both zero, you do not have a connection to your wifi network.

If you’ve got the pi up and running with a keyboard and monitor, can you open a terminal window and modify the interfaces file to resemble the following.

sudo nano /etc/network/interfaces

You should see something that resembles the following. Can you enter your network information in SSID and PSK, and then reboot and check your internet connection again (ipconfig and then values of Rx and Tx).

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
auto wlan0

iface wlan0 inet dhcp
        wpa-ssid "SSID"
        wpa-psk "PSK" 

#12

Thanks for sticking with me. I found part of my problems; I’m using a router with a WEP key. There was a reference for dealing with RPi and WEP keys which shows this code in the interfaces file:

auto wlan0
iface wlan0 inet static
wireless-essid YOUR_SSID_GOES_HERE
wireless-key 0123-4567-89
address YOUR_IP_GOES_HERE
netmask YOUR_NETMASK_GOES_HERE
gateway YOUR_GATEWAY_GOES_HERE

So I edited my file to look like this with my network particulars; still no connection.

Any ideas??


#13

Hmm. I’m not sure that the RPi can connect to a WEP network. I was scrolling through this: http://www.raspberrypi.org/forum/viewtopic.php?f=91&t=9612 and it seems to indicate it’s a tough thing to do.

There’s a comment down the line that seems to offer an answer, they linked to this site:

It might be worth trying, no?