VNC Error Code 1006

r4r
vnc
faq

#1

It really seems there should be a definitive answer to this by now but I can find nothing useful here or elsewhere. I have gone through the tutorials and searched the internet without luck.
We have 7 GoPiGo robots for use in our robotics club. All came from Dexter with the GoPiGo3, Raspberry Pi 3 & Dexter OS. All work fine.
Now we want to switch to Raspbian for Robots. Attempting to connect to VNC or NoVNC produces the Error Code 1006. Reflashing different SD cards doesn’t help. Switching to the CINCH version doesn’t help.
We can always log into the terminal window and also use PuTTY to ssh in.
pinging works fine.
This is on 2 separate computers, one Windows 7 and one Windows 10
I tried looking at the Windows 10 firewall and that appears ok but maybe not.
I also downloaded a VNC Viewer which produces a connection refused error.
With CINCH, both 10.10.10.10 & 10.10.10.10:8001 produce the same error code 1006.
Suggestions?
Thanks.


#2

Hi @wiltonkirk,

I have a couple of questions for now:

  1. When you SSH to your Raspberry Pi, do you use the dex.local address or do you somehow use the IP address?

  2. Do you use the latest version of Raspbian For Robots?

Also, looking at your situation makes me think there’s something preventing you to connect to your VNC server. Most likely there’s a LAN side firewall that’s blocking it.
Error code 1006 is a quite general error code for VNC and it could be because of a firewall that’s blocking it and I’m thinking that it might be the router. In all tests you’ve done, you didn’t tell me that you’ve changed the router, so I’ll assume you didn’t.

If that’s so and you tried on the same router every time, then could you connect the Pi to your computer, make sure you have Bonjour installed (that’s on the Windows machines, on Linux you’d have to use Zeroconf) and then try to access dex.local again? If it doesn’t work the first time, please be a bit more persistent and reload it a couple more times until it gets going.

I’m curious to see what’s the outcome of all these.

Thank you!


#3

Hi,
Thanks for replying.
ssh (PuTTY) using 10.10.10.10 & also 10.10.10.10:8001
Yes latest Raspbian for Robots version, just downloaded & flashed to a
new SD card, a few times.
SD cards are SanDisk Ultra microSDHC UHS-1, 16 GB, 98 MB/s
And also tried RfR CINCH with same result.
Correct, same router each time.
Good point, I will look at the router.
It is a new TP-LINK AC1900.
I am working with both a Windows 7 Dell & Windows 10 ASUS laptop.
I will also look at Bonjour.

This forced me to go back to the DexterOS which turns out to be a good
thing.
There have not been any connectivity problems with our 7 GoPiGo robots
running DexterOS.
We selected the GoPiGo for our robotics club here in Mathews, Virginia.
It looks like using Python in DexterOS will work fine for now.
Bloxter is great for those with little coding experience and having
Python right there when ready to advance.

Thanks,

Mike Kirk

Mentor, FIRST Team 1137 ‘Rocket Sauce’


#4

Hi Mike,

You probably already tried this, but did you add a “:1” after the address when using VNC (so xxx.xxx.xxx.xxx:1) ? Took me some time to figure that one out.

rgds

Jacco


#5

This is FANTASTIC news! So glad to hear it!