VNC Viewer and WiFi Problems[SOLVED]


#1

Hey guys,
So far I have done all the steps on the guide leading up to connecting the raspberry pi to a wifi connection.

I have connected to the terminal and logged in, have my wifi adaptor plugged in, and VNC viewer is downloaded. I imaged a micro SD I had using the instructions you guys provide on the website.

When I enter “raspberry.local:1” the following appears

VNC Viewer: The Connection was refused by the host computer

I have tried disabling my firewall and antivirus. I am trying to do this from a college wifi which may be the problem but any solutions would be great. Thanks!


#2

Good monring. I am having identical issues after following these steps:

  1. Performing firmware updates.
  2. Connecting via Ethernet.
  3. Connecting via WiFi using putty and VNC to get to what I assume is primary Raspbian splash screen.
  4. Subsequent attempts to connect using VNC fail as Grubs as noted in original post above while putty session still connects.
  5. Direct desktop connection works and am able to see Linux kernel boot and get to “raspberrypi” login but then do not appear to have correct login/PW for root level access or to get to Raspbian desktop?

Any help would be appreciated.


#3

Hey,
Can you have a look at the image that you are using and post the image name. The latest image uses dex.local as the username and robots1234 as the password. Can you try that out and let us know if it helps.

-karan


#4

Hey codebreakers,

One thing is confusing about the post: did you initially succesfully login and run the update? When you say your ran firmware update, did you mean you ran the software update?

Also, I would try Karan’s suggestion above if you’re using the latest image or have done and update. If not, you wrote that you used “raspberry.local:1” you should try the real hostname which is “raspberrypi.loca:1”


#5

Karan and John, to clarify, when initially setting up the GoPiGo, I successfully connected using putty (Host Name - raspberrypi.local, login as: pi, pi@raspberrypi.local’s password: raspberry), then successfully connected using VNC (VNC Server - raspberrypi.local:1; password – raspberry) and got what I assume is the standard Raspbian GUI which included the “Di” software update utility. Per the standard setup instructions found at this link, I attempted to run the Di utility which failed at the Linux command line and then followed these instructions to successfully update the software and firmware (I think) manually. Perhaps I’ve only updated the software or firmware and not both?

  1. Make sure robot connected to internet: ping google.com
  2. cd ~/Desktop/GoPiGo
  3. sudo git pull – pulls all firmware updates to local robot from Dexter website
  4. Follow steps here minus trim settings - http://www.dexterindustries.com/GoPiGo/programming/python-programming-for-the-raspberry-pi-gopigo/add-trim-to-the-motors/

Karan, apologies, but I don’t know how to determine the image name I’m using per your post: “Can you have a look at the image that you are using and post the image name. The latest image uses dex.local as the username and robots1234 as the password. Can you try that out and let us know if it helps.” Can you clarify how to do this, and also where I would use the dex.local and robots1234 login to do so? Unsure if this helps, but please see attached picture of login page I get when I attach directly to the robot as a desktop; does this tell us anything, and is there a login and password I can use here to help?

John, just to confirm, I have been using VNC hostname “raspberrypi.local:1” with password “raspberry” and continue to receive “The connection was refused by the host computer” message.

Thank you,
Jim


#6

Guys, as further clarification on three points:

  1. The hyperlink I originally followed (“Using Your GoPiGo for the first time”) was http://www.dexterindustries.com/GoPiGo/getting-started-with-your-gopigo-raspberry-pi-robot-kit-2/5-using-your-gopigo-for-the-first-time which led me to the failed “Di Software Update” and the manual steps noted above.

  2. I ran the “sudo raspi-config” command at one point to expand the Raspbian for Robots SD card which came with the kit.

  3. At one point I could not connect to the robot at all even using putty and it turns out the file system was corrupted based on booting to the desktop which was in read only mode so I ran fsck manually which cleaned up the issue, then I was able to connect using putty and the WiFi dongle but am still getting the VNC host error.

Whew!

Thanks again,
Jim


#7

Hey Jim, thanks for the detailed explanation of what went on. It sounds like the SD Card was corrupted and the fsck only repaired part of it.

If you’re still trying to get on VNC, would you be up for re-burning the sd card with the latest image?


#8

Latest image link being here: https://drive.google.com/open?id=0B0WChwP4CnLBRWlQU1hkMi1SOWc


#9

John, success! After downloading the latest image and installing per this link (http://www.dexterindustries.com/howto/install-raspbian-for-robots-image-on-an-sd-card/) I’m now running version 6.6 dated 11.4.15 which also solved an issue with the Scratch remote sensor not starting.

One last question, please - am I correct in assuming the Di Software update utility does the same thing as downloading and re-imaging the SD card with the latest image?

Thanks again,
Jim


#10

Hey Jim,
The DI software update does download and update everything on the image to the latest version of the software that we have.

-Karan


#11

Hey guys,

So different topic but still related to the thread, I’m using WinSCP to log into my pi2 and I’m currently using the image titled “2015.11.09_Dexter_Industries_wheezy”.

I am encountering a problem however, when I try to connect to my pi2 (be it putty or WinSCP) I enter the username as dex.local and the password as robots1234 but I receive an access denied prompt from the console. I have also tried the combination of username: pi and password: raspberry but I still get the same error.

Am I using the correct login information?

Thanks!
-Grubs


#12

Hey Grubs,

Username is Pi and the password is robots1234.

The hostname is now dex, so the bonjour/network access is dex.local.

Best, John


#13

Awesome it worked! Thanks so much!


#14

hey
i followed all the steps and got VNC and puTTY successfully moving my GoPiGo. i downloaded VNC Viewer onto my laptop and i put dex.local:1 into the server and it comes up with connection refused by host computer. I’ve tried doing it again without and firewall or anitvirus and it still come up with the same thing.

Ethan


#15

the first part about the vnc and putty working was on my desktop


#16

Hey funnies,
Did you try entering dex.local in your browser and check if it serves a webpage wit the VNC and SSH options. Also, which image are you using right now.

-Karan


#17

im using the 2016.05.16 jessie zip and imnot to sure what the browser is.


#18

So it’s working on your desktop, but not on your laptop, am I understanding right?

If that’s the case, is it possible for you to connect to the Pi on your desktop, and get the IP address?
Hover over the wifi symbol at top right, and you’ll get a popup window with the IP address. Disregard the /24 that also appears.
You can use that IP on your laptop VNC Viewer, like this:
192.168.x.x:1 (replace the x with whatever values your Pi has)


#19

it still says connection refused by host computer


#20

Hello funnyies, still not clear: did you run this on a browser? Can you provide a screenshot of the problem you’re seeing?