WiFi connection - dongle not recognized(?)


#1

I have two RPis - one that is running standard Raspbian, and one that I received with my BrickPi + custom SD from Dexter.

I have one wifi dongle. When I connect it to my “regular” RPi, it works fine.

When I connect it to the RPi /w Dexter distribution, the lights blink on the adapter, but the RPi doesn’t seem to recognize the wifi adapter.

— could this be a software update issue of some sorts (not sure how to update /w no connectivity…)?
— could this somehow be triggered by power source issues (no idea why it would make a difference)?
— do I need to make any edits/changes on the RPi in order for it to be set up for wifi (I don’t remember if/how I set up my older one)?

anything…?

tnx!


#2

Hey orenf, what sort of wifi dongle are you using?


#3

just typical usb wifi dongle (made by “ipTime”, a Korean company), supports wireless N. Works with one Pi, not with the one using the Dexter SD card).

Haven’t had time to switch SD cards and rule out Pi HW issue (unlikely though).


#4

Update:

Just confirmed the issue is (somehow) with the Dexter distro on the SD card — I switched SD cards, used the one from my old RPi in the new BrickPi — and the wireless adapter was all up and running.

So…

If there some manual config I need to do in order for the RPi to see the adapter (it’s not just the networks, it’s the adapter that is not showing up)?

[the adapter is getting power, it’s blinking and all, just not recognized by the RPi]

Do I need to apt-get update/upgrade the new RPi in hopes of getting it to work? Will it undo/harm the custom Dexter stuff?

?


#5

Hey orenf,
Not being a total expert on this, I’ll hazard a guess.

  • I would recommend doing a “sudo apt-get update” and a “sudo apt-get upgrade” may indeed update with your wifi adapter info.
  • It should not harm any of the changes we made to the distro.
  • When you run “lsusb” what do you see?

Best,

John


#6

Just to confirm, it won’t harm the changes we made. I just tried both update/upgrade and lsusb. No problems with the image.


#7

We have the same issue “no-wifi” at the USB. We are running the Dexter Distro.
We tried 2 USB dongles as well as wired Ethernet.
So we can’t even run (get-apt update or upgrade).

The RPi is running fine on Raspbian (it sees WIFI and Ethernet)

Any ideas how to address this issue (no ethernet or wifi)?


#8

aallesch@gmail.com, can you post a screenshot of when you run “ifconfig”?

I’m assuming when you say ethernet, you tried to connect using Connect With Ethernet Cable, http://www.dexterindustries.com/BrickPi/getting-started/using-the-pi/, is that correct?

If you’re running win7, I believe there’s a way you can make a “bridge” and have internet access on your pi through your computer. You may also try to set it up through your network by plugging the ethernet cord directly into your router, rather than your computer, and then running these commands remotely to update the wifi details.

If that fails, one final strategy: hookup a monitor and keyboard, and plug the pi directly into your network via ethernet.

So . . . please let us know how it goes?


#9

No luck. We tried the bridge approach (described in the link). See attachment. We also plugged the RPi directly into the router. Still no luck.

In both cases all lights on the pie are shining. When we do into out router ADMIN setting and look at clients, we can see the RPi. But no ability to connect out side the local LAN.

Again, the RPi WIFI and Ethernet work with other Disto’s.


#10

scratch everything.
I got it work and the robot works too!
all i did was go to the config messed around,rebooted BAM!But even though i can install apps from the terminal, i cant go to the browser.its ok though. but for the good part the robot works.
thanks,
aallesch@gmail.com


#11

Could you post the contents of your interfaces and wpa_supplicant.conf files? I’ve been trying to connect to my wifi network all weekend.