Wifi connection problem


#1

I recently got my BrickPi about a week ago and I am having troubles with connecting the RPI to the internet.

I am connecting the RPI to my laptop via ethernet cable and into VNCViewer, and connected the wifi dongle to the RPI (obtained from the starter package), but I cannot seem to get the internet to work for the RPI so I can clone the github python examples.

When I check and scan for networks, it cannot look for the wireless networks.

I also typed in /etc/network/interfaces into the terminal and didn’t know what to put in for the ip addresses too.

Here is the /etc/network/interfaces :

Here is the ifconfig :

Please help and thanks.


#2

An update:

I am now using a TV as my desktop than my laptop and am connecting the RPI with an HDMI cable to it, along with a network cable from my router to the RPI too and still it doesn’t have an internet connection.

I reverted all changes to /etc/network/interfaces and it still doesn’t work. If I just connect the RPI with an ethernet cable, wouldnt it automatically have an internet connection?

edit:
When I type in ifconfig into the RPI terminal, it doesn’t show a “wlan0”, only “eth0” and “lo” unlike this image from the Adafruit guide:


#3

I too am having difficulties obtaining an internet connection via ethernet and/or wifi. I think that I may have two different root command lines because I get an error message when I attempt to edit it. Does anyone know how to edit/remove the root command for network interfaces so I can start over? Thanks.


#4

Hello Zewwo,
You mention that even a wired connection to your router doesn’t work. Is your router configured to hand out IP-addresses with DHCP, or does every device in your network require a static address?
The default network configuration /etc/network/interfaces on the pi configures eth0 to obtain an address automatically with DHCP, so a DHCP server has to be available in your LAN.

Please post the contents of your /etc/network/interfaces file and the output of ifconfig (just the text, doesn’t have to be a screenshot).


#5

zewwo,

Sorry to hear about these challenges with the wifi. We’ve seen problems with the wifi gui as well, and we’re working to correct them with a new image build in the next few weeks.

So if you’ve got this setup as a desktop, here are some changes to make to get running:

On your first post, you have a screenshot of /etc/network/interfaces. Did you change the SSID and the PSK to match your network settings? Also, you need your Subnet mask and you gateway to match those of your network. You can get your network settings easily: using a computer that’s already connected to the wifi network you want to join, open windows Command Prompt, and run “ipconfig”. If you’re connected to the network you want to connect your Raspberry Pi to, copy those settings over to your /etc/network/interfaces file.

To choose a static IP address, guess an appropriate number you want your raspberry pi to connect using. Test that number (make sure another device on the network isn’t using that number) by pinging it in the windows command prompt, again on a computer that’s connected to the network you want to connect to “ping 192.168.1.2” or whatever the IP address is that you want to assign. If the ping fails, the number isn’t being used on the network. If you get a ping response, try another valid ip number until you find one that’s not being used. Then change to that number on the address line of the interfaces file.

Since we’re assigning a static ip to the raspberry pi, DHCP should not matter. One problem with a network might be that it requires some validation or assignment from the router. Do new devices, when connecting to the network you’re using, need to be validated through the router admin? Or can you just type in the SSID and PSK to a phone or other device you’re using on the network, and join (no changes to the router)?

In your second post, you say that running “ifconfig” does show eth0 bute not wlan0. Is the wifi dongle plugged in when you don’t see wlan0?

Also, for what it’s worth, I’ve found it’s easier for some reason to use the wifi dongle on the bottom USB port. I don’t know why, but for some reasons wifi dongles sometimes SEEM to fail when plugged into the top USB port. Can you try switching the USB port as well?


#6

I had exactly the same problem as the original post – the wifi dongle showed up when I ran IFCONFIG, but with no data on it, and it did not show up on the GUI wifi program, just as in the screenshots above. I’m a newbie, so I spent a LONG time (several days) trying to figure this out – trying the the advice here, and trying alternative networking configurations that I found on other Raspberry Pi sites, and even ordering a new wifi dongle. After a very frustrating week, I hit upon the problem entirely by accident: my RaspberryPi (with accompanying BrickPi) was plugged into a USB power supply, but I did not also have the battery pack connected to the BrickPi. When I happened to connect the battery back, the LED on the wifi dongle blinked for the first time and… I was off to the races. I guess that, with the BrickPi connected, there was insufficient power from the USB alone to run the wifi dongle. While someone else might search the forums and eventually find this post, I think it would be very helpful if, in the “Getting Started” page on your web-site where you explain how to connect via wifi, you would mention that a battery pack is needed, in addition to the USB, in order to provide adequate power to the wifi.

Thanks!

Jeff


#7

Hey Jeff, thanks for this thoughtful note on the Wifi device. Indeed, we’ll update the directions, this is really helpful.

A quesiton about the power source you used: was it the DI power source, or another? Do you know the max output of the power source you were using?


#8

The USB power supply has output of 10W (5.1V, 2.1A). The BrickPi I am using is an older one (purchased in December, 2013), as is the R-Pi.