Wifi Driver


#1

I am 10 years old and I am trying to get the wifi working on my GoPiGo. The Raspberry Pi can see the Wifi Dongle, but I can’t get the Wifi to work. I think the problem is that I cannot install the drivers that came with the dongle because my computer does not have a cd player. I tried to download some drivers off of the internet but it didn’t work. (Maybe because I am not sure how to install them from an internet download.)

Can anyone help me get my Wifi working without a cd player.


#2

Hey Lucas,
When the WiFi dongle is connected to the Raspberry and you are logged on, type this in the terminal: ifconfig . If you see something like wlan0 then the Raspberry Pi is able to detect the WiFi adapter. Follow the steps here: https://learn.adafruit.com/adafruits-raspberry-pi-lesson-3-network-setup?view=all and you should be able to setup the WiFi easily.

Let us know if you face any more problems.

-Karan


#3

Hi Karan,
I am not finding the wlan0. What is see when I type ifconfig is eth0 Link encap:Ethernet There is more but I looked through the whole thing and there is no wlan0. Also, I looked through that page and when I scan on the Wifi Config, I get no results. Do you have any advice on what I can do now?

Attached is a picture of what comes up when I type ifconfig


#4

Which wifi module are you using?
Are you using the Dexter Industries Raspbian for Robots version of the SD Card image?


#5

Hi John,
Yes, I am using the Raspbian SD Card. I am using the Monoprice Wifi Dongle. Here is a link to the dongle page:

Lucas


#6

Sorry Lucas, the link didn’t come through.


#7

Sorry, will this come through?


#8

Hey Lucas, sorry, still can’t see any link. Any way you can just past a link in there? The text? Without using the “LINK” button above?


#9

Ok, here is the link:
http://www.monoprice.com/Product?c_id=105&cp_id=10501&cs_id=1050108&p_id=8072&seq=1&format=2


#10

That’s weird that it doesn’t work with the Raspberry Pi or show up, it looks just like the ones we sell on our website. It should work with the latest version of Raspbian for Robots. (http://www.dexterindustries.com/howto/raspberry-pi-tutorials/install-raspbian-for-robots-image-on-an-sd-card/)

What version of the operating system are you using? Did the SD card come with the starter kit?

Also, just checking: did you boot the Pi up with the Wifi Dongle in place?

How are you powering the Pi?


#11

I checked the DI Software Update and it told me firmware version 1.2 Is that the operating system?

We bought the GoPiGo Raspberry Pi University Engineering Kit and the SD card did come with the kit.

I did boot my pi up with the wifi dongle plugged in.

We power the Pi with the Raspberry Pi Power Supply. The GoPiGo (red part) is powered with batteries.

Lucas


#12

Hey Lucas,

Can you contact us through our contact us page here (http://www.dexterindustries.com/site/?page_id=65 )

I answer those and if you send me your address, I’ll send you another wifi module to try out. It sounds like the wifi device might not be registering with the Raspberry Pi.

Sorry about the troubles. We’ll try to figure this out asap.

John


#13

And, I should have added, if I understand how you have it setup correctly, you have set it up correctly and it should work. Maybe a replacement or another wifi device will work. Just let me kn ow your address and we’ll send you one to try out.


#14

Hey John,

I just received the full kit and can confirm the wifi does not work out of the box.

Some debug info before I start monkeying with things… I am using the WIFI dongle included, barcode 855947002552 and the included Raspbian for Robots 2014.07.30.

A cursory glance shows the device connected


pi@raspberrypi ~ $ lsusb
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. 
Bus 001 Device 004: ID 0bda:8179 Realtek Semiconductor Corp.

Unfortunately, as Lucas pointed out, no dice on the ifconfig


th0      Link encap:Ethernet  HWaddr b8:27:eb:c3:96:ee  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:8553 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2873 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:8761733 (8.3 MiB)  TX bytes:418813 (408.9 KiB)

eth0:avahi Link encap:Ethernet  HWaddr b8:27:eb:c3:96:ee  
          inet addr:169.254.12.69  Bcast:169.254.255.255  Mask:255.255.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:64 errors:0 dropped:0 overruns:0 frame:0
          TX packets:64 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:6048 (5.9 KiB)  TX bytes:6048 (5.9 KiB)

And just to confirm

pi@raspberrypi ~ $ uname -a
Linux raspberrypi 3.12.22+ #691 PREEMPT Wed Jun 18 18:29:58 BST 2014 armv6l GNU/Linux

And I don’t see a module loaded (but I don’t really know what I’m looking for)


pi@raspberrypi ~ $ lsmod
Module                  Size  Used by
bnep                   11030  2 
rfcomm                 33132  0 
bluetooth             225845  10 bnep,rfcomm
rfkill                 19567  2 bluetooth
i2c_dev                 5277  0 
snd_bcm2835            18169  0 
snd_soc_wm8804          7833  0 
snd_soc_pcm512x         8909  0 
snd_soc_bcm2708_i2s     5486  0 
regmap_mmio             2818  1 snd_soc_bcm2708_i2s
snd_soc_core          128166  3 snd_soc_pcm512x,snd_soc_wm8804,snd_soc_bcm2708_i2s
regmap_spi              1913  3 snd_soc_pcm512x,snd_soc_wm8804,snd_soc_core
snd_pcm_dmaengine       5481  1 snd_soc_core
snd_pcm                81518  3 snd_bcm2835,snd_soc_core,snd_pcm_dmaengine
snd_page_alloc          5168  1 snd_pcm
regmap_i2c              1657  3 snd_soc_pcm512x,snd_soc_wm8804,snd_soc_core
snd_compress            8136  1 snd_soc_core
snd_seq                54581  0 
snd_timer              20353  2 snd_pcm,snd_seq
snd_seq_device          6485  1 snd_seq
leds_gpio               2055  0 
led_class               4119  1 leds_gpio
snd                    61518  7 snd_bcm2835,snd_soc_core,snd_timer,snd_pcm,snd_seq,snd_seq_device,snd_compress
spi_bcm2708             4808  0 
i2c_bcm2708             4719  0 

And without the headers on the system compiling any of the new drivers are a nogo currently so I need to hook this up to the back of my router so I can get on the internet with it.


#15

dmesg showed the usb wifi info as

[    2.471623] usb 1-1.3: New USB device found, idVendor=0bda, idProduct=8179

But the driver included doesn’t seem to support it…

I looked up the Realtek drivers with

find /lib/modules/uname -r-type f -name "*.ko" | grep -i rtl

and under the wireless drivers I saw 8192cu so I looked for an alias that matched the vendor and the product from the dmesg info

modinfo 8192cu | grep -i v0bdap8179

And it’s not listed there.


#16

I googled around and found http://ubuntuforums.org/showthread.php?t=2172877 which links to http://ubuntuforums.org/showthread.php?t=2150729

I picked up another pi and 16gb card so I have enough room to get the headers and try building the driver from monoprice http://www.monoprice.com/Product?c_id=105&cp_id=10501&cs_id=1050108&p_id=8072&seq=1&format=2


#17

Hey Lee,

Can you tell me which version of the image we shipped you? Which date is on it?

I’m using the very latest right now and just had no trouble getting connected with a monoprice wifi (same one I think everyone on this thread has, I got it from our stock). My details:

I have an IP address (took me about 5 minutes the first time I connected to my wifi device) and when I ping google ‘ping google.com’ I get a response.

What’s even more strange: the wifi device I’m using was “broken” and I exchanged it with a student the other night. ANd it works now.


#18

DI Raspbian for Robots 2014.07.30.


#19

Can you do a fresh reboot and if it’s still working send me the output of the following commands?

  • uname -a
  • lsusb
  • find /lib/modules -type f -path "*wireless*" -name "*.ko"
  • lsmod

And a moonshot- can you see if you get anything from modinfo 8192cu | grep -i v0bdap8179

Thanks!


#20

Lee, Lucas,

I have two of these Monoprice dongles. One works with the old image and with the new image. One does not work with either image.

I think we may have a quality problem on our hands and it might not have anything to do with the the software or the SD Card Image.

Lee, the one I have that works lights up the red LED inside. The one that doesn’t work remains dead, no red LED. What does yours do?