Wifi Not working


#1

Thanks guys for the help and responses on the last posting. Updating software to latest configs made things better. I would suggest you more clearly state that this is a must do on updating software (I did not buy my system that long ago). I have a couple more questions that may be related to this update and screens

  1. when I run wpa-gui I can not see any wifi nets. I can see them if I run ifconfig -all in command window or look on the PC Wifi info (I am running Windows 10). I can only see wlan0 on wpa-gui. I have run IR receiver setup and disabled. Not see networkds means I can not connect to the dongle. I have reboot everything several times including routers and looked in posting (all are older). I am tried using TP-link (router), verizon Jetpack (a broadband cell device router device) and apple Iphone hotspot all with no luck. Suggestions?

  2. I now see in the new software an app “DI software update” Should I run this too since I just down loaded new software? This instructions on its use are not clear either.

Thanks again. I am making progress when real work does not get in the way


#2

Hi jondhagar, our pleasure! Can you tell me which version of Raspbian for Robots you downloaded and installed? What was the date on the zip file and the name of the zip file?

Thanks!


#3

Here is what I down loaded

2016.03.28-Dexter_Industries_wheezy.zip

I loaded this on to the robot as instructed.

getting the wifi dongle working is where I am stuck.


#4

If you started with the 2016.03.28 version, there’s no need to run an update. This is pretty well up to date.

So, you’re not seeing the wifi dongle show up in the wpa_gui.

“I can only see wlan0 on wpa-gui.” - That should indicate that the wifi dongle is in place I believe. The dongle is there. When you scan, are you not able to find your wifi network listed? Is that the problem?


#5

The Dongle is in place, and yes, when I do a scan I can not find my local wifi router(s) listed to connect to. The effect is I can not put the robot on the wifi network to program it. I must stay on the hardware connection.


#6

So your wifi dongle can see the network to connect to. It sounds like the wifi dongle is working fine: you can see the wifi network from it.

When you try to connect, what happens? Are you sure you’re using the right wifi password?


#7

No, the wifi dongle only sees itself. No other connects show up. Zero. Nada.


#8

Which version of wifi dongle are you using? If you run “lsusb” in the command line, what shows up? Did you buy the wifi dongle from us, or somewhere else?

Maybe you can take a screenshot of the problem with wpa-gui as well?


#9

I am using the wifi dongle I got from you guys. It says Monopece. I get the following from lsusb
001 device 002: ID 0424: 9514 standard microsystems corp.
001 device 001: ID 1d6b:0002 Linux foundation 2.0 root hub
001 device 003: ID 0424:ec00 Standard microsystems corp.

Working on a screen shot


#10

Could the wifi dongle not be working? I’ve tried this image with the older monoprice dongles and it seems to work. Does a light (blue or yellow) light up on the wifi dongle?


#11

That’s strange though, we haven’t sold those wifi dongles since early 2015 I think.


#12

I bought my device in late 2015. It came with old software and now I find old hardware ;-(


#13

Is the sad face really necessary?

Does a light (blue or yellow) light up on the wifi dongle?

Where did you purchase it from? If you bought it from us, we will of course make you whole.


#14

Well, I actually put a ; in the sad face, so I am not overly sad as I had a wink in there, just not making a much progress as I’d like.

The light is inside of the wifi dongle, not on the side, and yes I purchased the dongle from you guys.

I got the dongle to light up by moving to another USB connection. So I’ve made some progress as I can now see another network connection, but only 1 should I see more? Should it have the names of the wifi networks as your web site outlines? I see one connection called Dexter and one called WIRE591. My PC can see several others that I connect to and none are named WIRE591.


#15

Hey jondhagar,

I’m still a little confused about what you’re seeing at this point. So WIRE591 is a network that’s showing up, but you can’t see this network anywhere else? You should see all the available networks in your wifi configuration after you run “scan”. Once you’ve scanned, you should see all available wifi networks in the physical area that the wifi device can see.

John


#16

You have the problem. I can only see 1 or 2 items, such as WIRE591 and dexter:0, showing within VNC’s tool when I run scan. I can many more when I check the wifi finder on my laptop that I connect the PC to, but not the ones I see like WIRE591. The instruction say I should connect the raspberrypi to same network as the PC is connected to. I can’t see how to do that.


#17

Hey jondhagar, do you have any other mini wifi dongles you could use to see if the problem is with the wifi dongle? If you use a different one, do you see a lot of networks, or the same thing?


#18

I tried some other wifi devices. I got one to work that I use for my solar system. It sees the routers now, but it is a pretty large stick.

The dongle gives me the pic I send in powerpoint.


#19

That looks like it’s working and has a network setup on it. The picture is super grainy, so I can’t be sure about what’s going on. Do you now have a connection?


#20

The wifi dongle you provided is not finding any connection. I have another wifi stick that does find connections. I guess I’ll buy another wifi dongle myself since yours is not working.